9 Replies Latest reply on Apr 7, 2007 8:32 AM by Newsgroup_User

    Module won't run on IIS

    Level 7
      I verified the installation by navigating to the appropriate folder in the
      IIS Manager of the default web site. It's there.

      However .. when I try to navigate to http://localhost/mypanel.mxml which I
      placed in the root, the file isn't found and the browser (I have tried both
      Firefox and IE7) is trying to go to http://www.localhost.com .. huh?

      I can go to any other of my sites on localhost .. or any other file in the
      main root and it's http://localhost/nameoffile and it's found .. but for
      some reason, this is trying to add the .com onto localhost with an mxml file
      only.

      Why?

      Thanks!

      --
      Nancy Gill
      Adobe Community Expert
      Author: Dreamweaver 8 e-book for the DMX Zone
      Co-Author: Dreamweaver MX: Instant Troubleshooter (August, 2003)
      Technical Editor: DMX 2004: The Complete Reference, DMX 2004: A Beginner''s
      Guide, Mastering Macromedia Contribute
      Technical Reviewer: Dynamic Dreamweaver MX/DMX: Advanced PHP Web Development


        • 1. Re: Module won't run on IIS
          Ivascu Cristian
          Hi,
          Did you reboot your machine right after the installation was completed, and before trying to access an mxml file? It seems that because of some PATH issues the compiling component isn't located by the IIS ISAPI Filter until a full system reboot takes place. You should also check that the file you copied in the root folder does not have any specific security restrictions - e.g. the IUSR_ and IWAM users are not allowed to read the file. This is on of the cases when the browser tries to append www and .com or other domain extensions to localhost.
          If possible please post your configuration (OS version, IIS version) and the steps you took to get it installed.
          P.S. You should check the IIS Manager to see if the default web site has the mod_flex ISAPI Filter installed and enabled.

          Hope this helps,
          Cristian
          • 2. Re: Module won't run on IIS
            Level 7
            Thanks for responding.

            > Did you reboot your machine right after the installation was completed,
            > and
            > before trying to access an mxml file?

            Yes.

            You should also check that the file you copied in
            > the root folder does not have any specific security restrictions - e.g.
            > the
            > IUSR_ and IWAM users are not allowed to read the file.

            That's a thought .. I'll check that out.

            > If possible please post your configuration (OS version, IIS version) and
            > the
            > steps you took to get it installed.

            OS: Win XP Pro, SP2
            IIS: 5.1

            The steps in the instructions. I have Flex Builder 2.01 so I directed the
            Flex SDK path to the SDK folder in Flex Builder. I specified the other
            things in the installer and was directed to reboot upon successful
            completion. I did so.

            > P.S. You should check the IIS Manager to see if the default web site has
            > the
            > mod_flex ISAPI Filter installed and enabled.

            I have done so and it is. I did notice that it says Priority: Low .. is
            that correct:

            Thanks,
            Nancy


            • 3. Re: Module won't run on IIS
              catalinanastasoaie
              Hi,

              After the PC rebooted did your default browser opened displaying a page with links to the samples that have been installed along with the Flex Module?

              Did any of the samples worked for you?

              On which port have you installed IIS? If it is other than :80 you need to type http://localhost:[YOUR_PORT in order to display the page from your document root?

              Regards,
              Catalin Anastasoaie
              • 4. Re: Module won't run on IIS
                Level 7
                Yes .. the page with the links works .. but none of the samples do. Both
                Firefox and IE just hang and time out. When I try to go to the mxml page
                that I have in the root, the status bar shows that it changes my URL of
                http://localhost/mypanel.mxml to http://www.localhost.com which of course
                cannot be found.

                Yes .. IIS is installed on Port 80. And my localhost works fine for
                everything else.


                --
                Nancy Gill
                Adobe Community Expert
                Author: Dreamweaver 8 e-book for the DMX Zone
                Co-Author: Dreamweaver MX: Instant Troubleshooter (August, 2003)
                Technical Editor: DMX 2004: The Complete Reference, DMX 2004: A Beginner''s
                Guide, Mastering Macromedia Contribute
                Technical Reviewer: Dynamic Dreamweaver MX/DMX: Advanced PHP Web Development

                "catalinanastasoaie" <webforumsuser@macromedia.com> wrote in message
                news:eto5um$uf$1@forums.macromedia.com...
                > Hi,
                >
                > After the PC rebooted did your default browser opened displaying a page
                > with
                > links to the samples that have been installed along with the Flex Module?
                >
                > Did any of the samples worked for you?
                >
                > On which port have you installed IIS? If it is other than :80 you need to
                > type
                > http://localhost:[YOUR_PORT in order to display the page
                > from
                > your document root?
                >
                > Regards,
                > Catalin Anastasoaie
                >


                • 5. Re: Module won't run on IIS
                  catalinanastasoaie Level 1
                  Hi,

                  Could you tell us what version of JRE are you using?

                  Regards,
                  Catalin
                  • 6. Re: Module won't run on IIS
                    Level 7
                    Java(TM) 2 Runtime Environment, Standard Edition
                    Version 1.4.2

                    as part of Flex Builder 2 .. I pointed to the Flex SDK in Flex Builder 2
                    during installation. Was that correct?

                    Nancy

                    "catalinanastasoaie" <webforumsuser@macromedia.com> wrote in message
                    news:eton78$l45$1@forums.macromedia.com...
                    > Hi,
                    >
                    > Could you tell us what version of JRE are you using?
                    >
                    > Regards,
                    > Catalin


                    • 7. Re: Module won't run on IIS
                      catalinanastasoaie Level 1
                      Hi,

                      We have discovered that Flex Module isn't working with jre 1.4.2. We will release in few days a new version of Flex Module that will contain the fix for this. Please accept our apologies for any inconvenient provided by this issue.

                      Regards,
                      Catalin

                      • 8. Re: Module won't run on IIS
                        Level 7
                        Ah .. thanks. I'm surprised since that is the version in Flex Builder
                        2.0.1. I'll watch for the new version.

                        Nancy

                        "catalinanastasoaie" <webforumsuser@macromedia.com> wrote in message
                        news:etophi$o22$1@forums.macromedia.com...
                        > Hi,
                        >
                        > We have discovered that Flex Module isn't working with jre 1.4.2. We will
                        > release in few days a new version of Flex Module that will contain the fix
                        > for
                        > this. Please accept our apologies for any inconvenient provided by this
                        > issue.
                        >
                        > Regards,
                        > Catalin
                        >
                        >
                        >


                        • 9. Re: Module won't run on IIS
                          Level 7
                          > We have discovered that Flex Module isn't working with jre 1.4.2. We will
                          > release in few days a new version of Flex Module that will contain the fix
                          > for
                          > this. Please accept our apologies for any inconvenient provided by this
                          > issue


                          This post is now a couple of weeks old. Was the new version ever released?

                          Thanks,
                          Nancy