1 Reply Latest reply on Nov 26, 2014 2:32 AM by BKKDon

    Hi there, I have a Mac 10.5 version and would like to use lightroom. I have been told that I can only use Lightroom 3.3 but do not know where to purchase it, also, can I tether my Canon 6D with that lightroom?

    yazzz.

      Hi there, I have a Mac 10.5 version and would like to use lightroom. I have been told that I can only use Lightroom 3.3 but do not know where to purchase it, also, can I tether my Canon 6D with that lightroom?

       

      Many Thanks

       

      Yaz