2 Replies Latest reply on Nov 27, 2014 8:55 AM by wattapic

    is mac os x 10.7.5 compatible with Lightroom 5?

    wattapic

      My iMac runs os x 10.7.5--will it be fully compatible with Lightroom 5?