2 Replies Latest reply on Nov 22, 2009 11:11 PM by Mugunda

    Module Loader Error - SWF is not a loadable Module

    pursuantgroup2
      I am getting the error: "SWF is not a loadable module"

      I am trying to use a flash projector file to load a module from a remote host. Using the modular application model, I created a module, and then a shell (which I will make into a projector) to load in the swf from the web.

      Scenarios:
      Works: When I run the shell locally (shell run locally as swf - "module.swf" is local)
      Works: When I run the shell on the web (shell run remotely as swf - "module.swf" is on the same server called with full url)
      Does Not Work: When I run the shell locally (as swf or exe) and call "module.swf" from the web using the full url. An error gets returned that says "SWF is not a loadable module".

      Other things you may want to know:

      crossdomain.xml file is in place and set : <allow-access-from domain="*" to-ports="*" />

      security in the module is: Security.allowDomain("*");

      security in shell is: Security.allowDomain("*"); Security.loadPolicyFile(" http://remoteservername/crossdomain.xml");

      All these are compiled where "-use-network=true".


      The error doesn't say anything about security issues, and from the examples, and documentation, it would appear that my simple request of running a flash projector calling an swf from the web should be no problem at all. Has anyone else done it?
      Thanks in advance for your help.