3 Replies Latest reply on Mar 24, 2015 8:23 AM by PoppyBio

    'Could not complete your request due to program error '

    greenseaweed

      Hello.

       

      I’ve had this error box [Could not complete your request because of a program error] pop up consistently with one photoshop document in particular today. Though this error has been a problem in the past, closing and opening the programme seemed to fix it. However today I’ve tried that and have uninstalled and reinstalled photoshop. I’ve also reset my preferences. Nothing has worked.

       

      I’ve found that this error normally appears when the file has timeline keyframes in it. This leads to being unable to open the file, or if the file is open I am unable to export the video due to program error or am unable to save the file due to program error.

       

      I’m running Photoshop cc 2014.2.1 x64 on Mac OS X 10.10.1


      Photoshop has all of the most recent updates installed.

       

      Below is all text from the PSErrorLog.txt document:

       

      2014:11:28 19:24:05 : /Volumes/workarea/PS_15_Mac_Daily_Retail/20141014.r.257/photoshop/main/photoshop/sources/ ULinkManager.cpp : 1380 : REQUIRE failed

      2014:11:28 19:25:09 : /Volumes/workarea/PS_15_Mac_Daily_Retail/20141014.r.257/photoshop/main/photoshop/sources/ ULinkManager.cpp : 1380 : REQUIRE failed

      2014:11:28 19:25:13 : /Volumes/workarea/PS_15_Mac_Daily_Retail/20141014.r.257/photoshop/main/photoshop/sources/ ULinkManager.cpp : 1380 : REQUIRE failed

      2014:11:28 19:25:18 : /Volumes/workarea/PS_15_Mac_Daily_Retail/20141014.r.257/photoshop/main/photoshop/sources/ ULinkManager.cpp : 1380 : REQUIRE failed

      2014:11:28 19:25:36 : /Volumes/workarea/PS_15_Mac_Daily_Retail/20141014.r.257/photoshop/main/photoshop/sources/ ULinkManager.cpp : 1380 : REQUIRE failed

      2014:11:28 19:31:23 : /Volumes/workarea/PS_15_Mac_Daily_Retail/20141014.r.257/photoshop/main/photoshop/sources/ ULinkManager.cpp : 1380 : REQUIRE failed

       

      Any help would be greatly appreciated. I've tried to include all the relevant information, but please let me know if I've missed anything out.

        • 1. Re: 'Could not complete your request due to program error '
          MatthewGore Level 1

          I'm getting the same error, but working on Windows 7/64. This is also video project with animation. However, I'm attempting to simply open a saved project. When I try to open it, I get the program error message. The error log says:

           

          2015:01:13 10:24:39 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

          2015:01:13 10:25:04 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

           

          Did you get this figured out, greenseaweed?

          • 2. Re: 'Could not complete your request due to program error '
            greenseaweed Level 1

            Hey Matthew. I haven't been able to figure it out unfortunately. It hasn't happened for a while, but I still have a fear it'll strike at any time. Hopefully somebody will figure it out in the future though, it'd be great to not have to worry about it.

            • 3. Re: 'Could not complete your request due to program error '
              PoppyBio

              Hello all

               

              I am experiencing exactly the same problem as people mentioned above. It is a video animation file. (Windows 7 / 64bit)

               

              My log file is as follows:

               

              2015:03:24 15:06:58 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:07:01 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:07:05 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:07:05 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:07:12 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:07:23 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:07:35 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:07:38 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:08:28 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:08:30 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:08:34 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:08:34 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:17:04 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:17:07 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:17:10 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

              2015:03:24 15:17:25 : ..\..\sources\ULinkManager.cpp : 1380 : REQUIRE failed

               

              Please help!

               

              Thank you