4 Replies Latest reply on Dec 1, 2014 1:53 AM by danieldietrich

    LR not seeing my external drive in Library Mode but does at Import

    danieldietrich

      Hi Team,

       

      I filled up a WD drive and got a new Seagate drive that I've put the last few batches of photos on. Wanting to visit a few photos on the WD drive (that remained in the same USB port as always), I noticed LR wasn't listing it in Library Mode. If I hit Import, it lists it and acts like none of the images have ever been imported before.

       

      I also have a 3rd larger drive that backed up the WD drive. In library mode, LR does see that drive.

       

      I am wondering how I can get the WD drive located by LR again ensuring that my edits to the images are there as well.

       

      FYI, I did do a catalog backup of the Seagate drive. Perhaps that new catalog only backed up the Seagate drive and can't see the WD drive? (but then why would the larger backup drive...)

       

      Thanks for any help you can lend.

       

      Daniel

        • 1. Re: LR not seeing my external drive in Library Mode but does at Import
          ssprengel Adobe Community Professional & MVP

          Library will only show you drives that you’ve imported from.  Import will show drives that are available whether or not you’ve imported from them.

           

          Has the drive letter changed on the drive that you don’t see in Library?  Is there another drive that is listed in Library that supposedly has all your photos but they all they missing?

          • 2. Re: LR not seeing my external drive in Library Mode but does at Import
            elie-d Level 4

            FYI, I did do a catalog backup of the Seagate drive. Perhaps that new catalog only backed up the Seagate drive and can't see the WD drive?

            That sounds like you have multiple catalogs, one for the WD and another for the Seagate. Look at File/Open Recent to see if the other catalog is listed. Having separate catalogs is not good practice, IMO, because you cannot make collections that span the two drives easily.

            • 3. Re: LR not seeing my external drive in Library Mode but does at Import
              danieldietrich Level 1

              Thanks for the reply. I have imported and edited tons of images from the WD drive. So definitely been imported from before. It shows up nowhere on the list. Not as the original drive I had been using, nor as a drive with ?s. Somehow, though, my other 2 drive letters/names did change. One I was able to point to the old location. The other is asking me if I want to combine/merge as the folder already exists. I cancelled this request.

               

              I did try to use the previous catalog from File-Open Recent. None of the drives showed up. No collections,etc. So I went back to the latest catalog. Same issue exists.

               

              Thanks so much.

              • 4. Re: LR not seeing my external drive in Library Mode but does at Import
                danieldietrich Level 1

                Hi elie,

                 

                I did try to use the previous catalog from File-Open Recent. None of the drives showed up. No collections,etc. So I went back to the latest catalog. Same issue exists.

                 

                I can't get LR to find the original WD drive anywhere (except import). But I have imported and used this drive for 10s of thousands of images. There seems to just be a disconnect with the drive and the catalog. I just can't seem to sort out how to connect the two. I first need to have LR find the WD drive. I don't know why it can't do so.

                 

                Thanks so much.