6 Replies Latest reply on Mar 10, 2015 6:56 PM by naldeau49

    "Locking existing frames" very slow

    natevplas Level 1

      When RAM previewing in the latest CC 2014, it says "Locking Existing Frames" for about 5-10 seconds every time, even if all the frames in the work area are already rendered.  Sometimes the green bar indicating rendered frames disappears immediately after hitting RAM preview again.

      I can't seem to reproduce the problem in another project.  I have 64 GB of RAM in my 2012 Mac Pro and an SSD for my disk cache (which I've also tried turning off with no effect).  An old post on here said people had this issue with CS4 and it was usually fixed by turning off audio and/or video layers.  This did not help.  I deleted all footage and audio so it is just two precomps with illustrator files and shape layers mostly.  Some 3D layers, but nothing crazy.  If I RAM preview the precomps they don't have this problem, it's just in the main comp where I have them sequenced together.  The main comp I'm trying to render is a bit long (2+ minutes) but I tried trimming it down to 10 seconds and this didn't help much.  I have Open GL and Render Multiple Frames Simultaneously off as well.  I tried duplicating the comp and when that didn't work I imported the project into a new, clean project file.  No luck.

      Anyone else having this problem and found a solution?  I'm open to any ideas.

        • 1. Re: "Locking existing frames" very slow
          Rick Gerard Adobe Community Professional & MVP

          Some video codecs and file formats cause more problems than others. Tell us more about your project. What kind of footage? OS and AE version down to the last decimal point would also be helpful.

          • 2. Re: "Locking existing frames" very slow
            natevplas Level 1

            Thanks for the response, Rick.  I'm on OSX 10.9.5 and AE CC 2014.1.1 Version 13.1.1.3.

            I actually already deleted all of the footage out of the main comp and out of the two precomps I left in there.  The footage I had in there before is Quicktime 1080 ProRes 4444 using RGB+A which I've used many times before without this issue.  There are no audio files in there either.

            I am doing some character animation and other stuff with Illustrator CS6 files and shape layers.  There are some nulls and solids and quite a few expressions for the character rigs (IK, etc).  Some 3D layers and cameras are involved.  I'm using very few effects- mostly fills and tints and the Puppet Tool.

            Anything else you need to know?

            • 3. Re: "Locking existing frames" very slow
              Davimead

              Hi Natevplas, this seems to be a massive issue at the moment. I have several colleagues working on AE CC 2014 and we all have the Locking Existing Frames issue!! It appears to have reared it's ugly head again as I'm sure it was cured several versions ago.the cure apparently seems to be turning off the audio, but  I can't turn the audio in my project off for rendering as I need to see it working with the pictures....so a catch 22 situation!!!

              Please, Please, Please Adobe sort this out as it is seriously hampering productivity!!

              I look forward to a swift response.

              Dave

              • 4. Re: "Locking existing frames" very slow
                Jamesmcw

                I was struggling with this issue recently and (at least for me) the problem could be related to the sample rate/bit depth of the audio files being used. I noticed it occured when I added a couple of VO recordings to my comp so I made sure to convert the audio files to 24bit 48khz and reimported into the project. The problem went away but of course it may just be that deleting the files from the project and reimporting them fixed the issue and changing the bit/sample rate was a placebo!

                • 5. Re: "Locking existing frames" very slow
                  Todd_Kopriva Level 8

                  Yes, it seems that the processing of the audio for the preview is what is causing the delay. Try muting the audio in the Preview panel, and I expect that you'll see this delay go away.

                  • 6. Re: "Locking existing frames" very slow
                    naldeau49 Level 1

                    if i could have seen your face when you wrote that, were you blushing with embarrassment? don't work with audio. sheesh, that's useful. (anybody able to work without audio?) multi-processing for previews is basically non-functional here. preview with multi-processing just doesn't work, with 32 gigs of ram and a fast external drive, afx gives the locking frames message and then sits there. this is on light comps even with no audio. had to turn off multi-processing for previews to even work. i'd hope there was a more immediate fix you could come up with, even short term, than turning off the audio and waiting for the rewrite of the afx core code.