1 Reply Latest reply on Mar 15, 2007 10:37 AM by Newsgroup_User

    Code works in Flash 6 not 8

    stellamay
      Hi, I really need some help with this one. I've looked through all the forums and across the web and can't find a solution. I am somewhat newish to Flash so i apologize in advance. I am making some basic changes to a preexisting website which was created in Flash 6. When I changed out an image and saved it to Flash 8 I get this message:**Error** /Users/myname/Library/Application Support/Macromedia/Flash 8/en/Configuration/Classes/toplevel.as: Line 68: You must export your movie as Flash 6 to use this action. #endinitclip
      Can anyone please please please help me fix this problem with compatibility? I would appreciate any help you can offer.
      Thankyou!
        • 1. Re: Code works in Flash 6 not 8
          Level 7
          stellamay,

          > I get this message:**Error** [...] You must export your movie
          > as Flash 6 to use this action. #endinitclip

          That refers to the #endinitclip directive, which was first available in
          Flash MX (aka Flash 6).

          > Can anyone please please please help me fix this problem with
          > compatibility? I would appreciate any help you can offer.

          How are you publishing this SWF file? Look in your Publish Settings and
          see if the SWF is being published for Flash 6. (I wouldn't think that a
          higher version would balk at #endinitclip, but it certainly would if you're
          publishing to, say, Flash 5.)


          David Stiller
          Adobe Community Expert
          Dev blog, http://www.quip.net/blog/
          "Luck is the residue of good design."