11 Replies Latest reply on Mar 28, 2007 11:24 AM by kglad

    Javascript Pop-up - Wait, this is different!

    In_progress
      I know I know.. This problem has been posted before.. But I truly believe my situation is unique. I've searched through the previous posts and nothing has shed any new light on my problem.

      I'm using javascript to launch a new window with custom parameters via Flash 8 (we all know how it works..)

      This is the code used on the button in the ActionScript area:

      2-square_btn.onRelease = function() {
      getURL("javascript:openNewWindow(' http://www.funktheweb.ca/test/2-square.html','height=100,width=750,toolbar=no,scrollbars=y es,location=no')
      }
      Text

      This is the script used on the HTML published page of the Flash file:

      <script language="JavaScript">
      function openNewWindow(URLtoOpen, windowName, windowFeatures) {
      newWindow=window.open(URLtoOpen, windowName, windowFeatures); }</script>
      Text

      I've tried using it "as is" and inputting the new window specifics in between the brackets (i.e 'www.adobe.com', '123', width=300.. etc...). However it doesn't work. Except for 2 instances when it did (where the script was used "as is"). I reload it unto my server everytime I make a change and clear my browser cache before viewing it.
      I don't understand why it worked twice, but not again. However, when it did work - it work like a regular "_blank" button, with none of my parameters intergrated in to the new window (probably because the script on the HTML published page has no specifics in the script).

      You can view the site in question (go easy on me it's still the beta) at http://www.funktheweb.ca/test ->under the gallery link, first thumbnail top left.

      Please help! What am I doing wrong?