8 Replies Latest reply on Jun 7, 2016 7:54 AM by sdsinc_pmascari

    Why are we getting 'Coldfusion 10 application server cannot be found'?

    clee_usace

      Our ColdFusion 10 Application Server would not start. It was running fine since server inception back in July until I got back to the office from vacation yesterday. Looking at the Event Viewer 'application' log, it's showing the following message:

       

      "The description for Event ID 259 from source ColdFusion 10 Application Server cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

       

      If the event originated on another computer, the display information had to be saved with the event.

       

      The following information was included with the event: ColdFusion 10 Application Server."

       

      I thought that the issue was caused by Hotfix 14. So I manually removed the hotfix and rebooted the server couple of times. However, ColdFusion still wouldn't start. Has anyone came across this issue before? I look forward to your response. Thanks.

       

      Best regards,

       

      Chung Lee

        • 1. Re: Why are we getting 'Coldfusion 10 application server cannot be found'?
          Carl Von Stetten Adobe Community Professional & MVP

          I don't think ColdFusion provides detailed information to the Windows Event logs, which is why you get kind of a misleading message in your event log.  You need to dig into the ColdFusion logs within your installation folder.  So go to <drive letter>:\ColdFusion10\cfusion\logs, and take a look at the "coldfusion-error.log" and maybe "exception.log".  You might also take a look at log files within <drive letter>:\ColdFusion\config\wsconfig and its subfolders.

           

          Let us know if you find any error messages added to the logs when you attempt to start the server.

           

          Also, you might try launching ColdFusion from the command line using the "cfstart.bat" script found in the <drive letter>:\ColdFusion10\cfusion\bin folder and see if any errors show in the command window.

           

          -Carl V.

          • 2. Re: Why are we getting 'Coldfusion 10 application server cannot be found'?
            clee_usace Level 1

            Hello Carl V.,

             

            Thank you for you reply. I digged through the coldfusion-error.log and the exception.log and came across errors that were last generated on 12/17/2014. On the exception.log, it's showing the following:

             

            "Error","Thread-17","12/17/14","15:15:54",,"Could not initialize class java.awt.Toolkit"

             

            java.lang.NoClassDefFoundError: Could not initialize class java.awt.Toolkit

             

                at java.awt.Component.<clinit>(Unknown Source)

             

                at coldfusion.document.JPedalFontRegistry.init(JPedalFontRegistry.java:40)

             

                at coldfusion.document.DocumentServiceImpl.initializeDocumentService(DocumentServiceImpl.jav a:211)

             

                at coldfusion.document.DocumentServiceImpl.access$000(DocumentServiceImpl.java:52)

             

                at coldfusion.document.DocumentServiceImpl$1.run(DocumentServiceImpl.java:180)

             

            "Error","localhost-startStop-1","12/17/14","15:15:55",,"Unable to initialise JAI service: java.lang.NoClassDefFoundError: java.awt.Toolkit"

             

            java.lang.NoClassDefFoundError: java.awt.Toolkit

             

                at sun.awt.AppContext$2.run(Unknown Source)

             

                at sun.awt.AppContext$2.run(Unknown Source)

             

                at java.security.AccessController.doPrivileged(Native Method)

             

                at sun.awt.AppContext.initMainAppContext(Unknown Source)

             

                at sun.awt.AppContext.access$200(Unknown Source)

             

                at sun.awt.AppContext$3.run(Unknown Source)

             

                at sun.awt.AppContext$3.run(Unknown Source)

             

                at java.security.AccessController.doPrivileged(Native Method)

             

                at sun.awt.AppContext.getAppContext(Unknown Source)

             

                at javax.imageio.spi.IIORegistry.getDefaultInstance(Unknown Source)

             

                at coldfusion.server.CFService.setupImageProviders(CFService.java:707)

             

                at coldfusion.server.CFService.start(CFService.java:690)

             

                at coldfusion.server.j2ee.CFStartUpServlet.startCFService(CFStartUpServlet.java:110)

             

                at coldfusion.server.j2ee.CFStartUpServlet.init(CFStartUpServlet.java:86)

             

                at javax.servlet.GenericServlet.init(GenericServlet.java:158)

             

                at coldfusion.bootstrap.ClassloaderHelper.initServletClass(ClassloaderHelper.java:121)

             

                at coldfusion.bootstrap.BootstrapServlet.init(BootstrapServlet.java:59)

             

                at org.apache.catalina.core.StandardWrapper.initServlet(StandardWrapper.java:1284)

             

                at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1197)

             

                at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1087)

             

                at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:5210)

             

                at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5493)

             

                at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)

             

                at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1559)

             

                at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1549)

             

                at java.util.concurrent.FutureTask.run(Unknown Source)

             

                at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)

             

                at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

             

                at java.lang.Thread.run(Unknown Source)

            • 3. Re: Why are we getting 'Coldfusion 10 application server cannot be found'?
              clee_usace Level 1

              I am not able to post the entire errors from the coldfusion-error.log since it's too long. So I am posting a snippet of the errors:

               

              INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\\ColdFusion10\\cfusion\lib;C:\\ColdFusion10\\cfusion\jintegra\bin;C:\\ColdFusion10\\cf usion\jintegra\bin\international;C:\\ColdFusion10\\cfusion\lib\oosdk\classes\win

               

              Dec 17, 2014 3:11:18 PM org.apache.coyote.AbstractProtocol init

               

              INFO: Initializing ProtocolHandler ["ajp-bio-8012"]

               

              Dec 17, 2014 3:11:18 PM org.apache.catalina.core.StandardService startInternal

               

              INFO: Starting service Catalina

               

              Dec 17, 2014 3:11:18 PM org.apache.catalina.core.StandardEngine startInternal

               

              INFO: Starting Servlet Engine: Apache Tomcat/7.0.54

               

              Dec 17, 2014 3:11:32 PM org.apache.catalina.util.SessionIdGenerator createSecureRandom

               

              INFO: Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [156] milliseconds.

               

              Dec 17, 2014 3:11:47 PM org.apache.catalina.core.ApplicationContext log

               

              INFO: ColdFusionStartUpServlet: ColdFusion: Starting application services

               

              Dec 17, 2014 3:11:47 PM org.apache.catalina.core.ApplicationContext log

               

              INFO: ColdFusionStartUpServlet: ColdFusion: VM version = 24.65-b04

               

              java.lang.NullPointerException

               

                  at coldfusion.server.jrun4.metrics.SimpleLoadMetric.run(SimpleLoadMetric.java:157)

               

                  at coldfusion.scheduling.ThreadPool.run(ThreadPool.java:260)

               

                  at coldfusion.scheduling.WorkerThread.run(WorkerThread.java:71)

               

              Dec 17, 2014 3:12:09 PM org.apache.catalina.core.ApplicationContext log

               

              INFO: CFMxmlServlet: Macromedia Flex Build: 87315.134646

               

              Dec 17, 2014 3:12:21 PM org.apache.coyote.AbstractProtocol start

               

              INFO: Starting ProtocolHandler ["ajp-bio-8012"]

               

              Dec 17, 2014 3:12:21 PM com.adobe.coldfusion.launcher.Launcher run

               

              INFO: Server startup in 74756 ms

               

              Dec 17, 2014 3:15:17 PM org.apache.catalina.core.AprLifecycleListener init

              • 4. Re: Why are we getting 'Coldfusion 10 application server cannot be found'?
                clee_usace Level 1

                Carl V.,

                 

                I ran the cfstart.bat to see if there would be any errors on the command window. There weren't any errors in the window, but I got a separate window which is showing the following message:

                 

                "Adobe ColdFusion Launcher Application has stopped working. A problem caused the program to stop working correctly. Please close the program."

                 


                Thanks,

                 

                Chung Lee

                • 5. Re: Why are we getting 'Coldfusion 10 application server cannot be found'?
                  clee_usace Level 1

                  Hello Everybody,

                   

                  Hope you all had a great Christmas.

                   

                  I would like to check in to see if anybody has an opinion on this issue? Thank you so much.

                   

                  Best regards,

                   

                  Chung

                  • 6. Re: Why are we getting 'Coldfusion 10 application server cannot be found'?
                    Carl Von Stetten Adobe Community Professional & MVP

                    Chung,

                     

                    It sounds like your ColdFusion installation is messed up.  When you installed, did you run the installer "As Administrator"? What user account does the ColdFusion service run under and does it have appropriate permissions to the various folders within the ColdFusion installation?  Did you follow the Lockdown Guide and perhaps miss a step or two?

                    -Carl V.

                    • 7. Re: Why are we getting 'Coldfusion 10 application server cannot be found'?
                      clee_usace Level 1

                      Hello Carl V.,

                       

                      Good to hear from you. We installed CF10 as instructed by the installation manual and the lock down guide. The installation has been working since the beginning (July) until the past couple of weeks. We ran the installer as administrator. We gave the ColdFusion service account admin privileges and applied its permissions to the CF10 installation folder.

                       

                      I'm guessing the possibility of a Windows patch or a server config modification that was done by our IT team when I was away on vacation. CF10 was working fine until I returned the office. I am contemplating of uninstalling and re-installing ColdFusion. I would have to access the existing ColdFusion configurations somehow and save them as a CAR file.

                       

                      Thanks,

                       

                      Chung

                      • 8. Re: Why are we getting 'Coldfusion 10 application server cannot be found'?
                        Carl Von Stetten Adobe Community Professional & MVP

                        Have you applied the latest ColdFusion 10 updates?  You can download them manually if needed and install them without going through the CF Administrator.  Also, you might be able to roll back any Windows updates to see if one in particular caused the problem.

                         

                        -Carl V.

                        • 9. Re: Why are we getting 'Coldfusion 10 application server cannot be found'?
                          ruocco Level 1

                          I had this and it turned out to be a problem with Java auto updating. The auto update removed the version of Java the jvm.config was looking at and placing the new version in a different folder. When you attempted to start the ColdFusion services error 'Event ID 259' would come up.

                          • 10. Re: Why are we getting 'Coldfusion 10 application server cannot be found'?
                            sdsinc_pmascari Level 2

                            FYI...just had same issue happen to me on CF11.  Ruocco is correct.  A Java auto update was to blame.  After re-installing Java we're back up and running.  Turned off Auto-update using MSConfig.