2 Replies Latest reply on Mar 9, 2007 12:01 PM by Fly Molo

    Project Not Checking out From Version Control

    Christina Stommel
      All of our help projects are managed using version control (Team Foundation Server).

      I recently had an XPJ file that became corrupted. As per Adobe's instructions, I deleted the XPJ and CPD files and regenerated the project from the HHP file. That worked fine, but now launching the project from the XPJ file opens the project outside of version control. (I'm no longer being prompted to check the files out.) I think this is because the newly created XPJ file now disassociated with the source control. If this is true, how do I get the XPJ file back into source control?

      Hopefully this makes sense.

      Christina Stommel
        • 1. Project Not Checking out From Version Control
          mike_genthner
          Hi Christina,

          My understanding of the entire "version control" process is limited but since no one else has thrown in, I will try to pass along what little I know. What I have learned is that version control works great until it doesn't.

          What I've had to do in the past, when I've had these sort of synchronization problems, is to remove the entire project from version control (I would be sure to back up your local project as well as your version-controlled project). Then, you should be able to add the repaired project back to your source control software (we use MS VSS but I think it shouldn't matter).

          I have tried, in the past, to add individual files to the database from the RH interface (you could try "check in all files") and I have gone into the database and manually added the necessary files, but I have had mixed results. In the end, it seems that removing the project from version control, then adding it back, is the only thing that is guaranteed to work.

          Good luck!
          • 2. Project Not Checking out From Version Control
            Fly Molo
            Hi Christina,

            In my experience with reimporting projects from the HHP file, all files in the project must be writable for the import process to work correctly. If all files in the project are writeable (not read-only) RoboHelp won't prompt you that 'To modify this document, the files in the list below need to be writable.' That Confirm Access dialog is generally my clue that I need to check a file out of source control.

            So it may be that there is no 'association' trouble, it is just that RoboHelp can write freely to the topics in your project so it doesn't complain. In short, RoboHelp thinks that you've already checked the files out. Check to make sure that files in your project are read-only.

            As an aside, the XPJ file is not a file I generally need to check out of source control, it is a fairly static xml file (please correct me if I am wrong anyone), so you might be able to eliminate some future file corruption problems. Hope this helps.

            //Lucas