0 Replies Latest reply on Dec 26, 2014 8:49 PM by Andrea Varney

    Is CS5 compatible with newer MAC operating systems?

    Andrea Varney

      I am running CS5 on an iMac 3.06 GHz Intel Core 2 Duo processor with Mac OS X 10.6.8. I would like to upgrade my OS to a newer version but do not want to lose use of CS5. Which OS X version would be best to upgrade to?