16 Replies Latest reply on Apr 27, 2015 12:00 PM by 0cw22

    ADE quits unexpectedly, each time I open a library EPUB book

    Michael Begg

      I just downloaded Adobe Digital Editions to read a library e-book on my Mac. I created an ADE id as well. When I opened ADE, I found the ADE help EPUB doc, and had a quick look at it. That document opened fine with just a double-click. I then double-clicked the ACSM file I had downloaded from my library. ADE created the EPUB file and added it to my ADE library--and crashed immediately, only giving me an "ADE has quit unexpectedly" dialogue box. I opened ADE again, and saw that the library book was in the list, next to the ADE help guide. I right-clicked the library book, and selected "Read". The program quit unexpectedly again (well, not as unexpectedly as the first time, from my point of view, but perhaps twice as frustratingly).

       

      I have tried three other things, with no success:

      1. Double-clicking the ACSM file in my Downloads folder. This only duplicated my first failure: ADE opened again, displaying a second copy of the book--but crashed immediately. I then looked in the "Digital Editions" folder the program created, and saw two versions of the EPUB file. (Each is 5 mb in size, compared to the 2kb ACSM file.)

      2. I opened ADE from my Applications folder, then selected File > Add to library > and chose the EPUB file. This added the book to my shelf in ADE yet again, this time with a "20 days" tag in the corner, showing how long I can have the book out from the library. I then double-clicked the book in ADE. ADE quit unexpectedly.

      3. I went back to the Digital Editions folder in my computer's hard drive and right-clicked the EPUB file. I selected "Open with ..."  and then clicked iBooks. The iBooks program refused to open the book, saying that it was corrupt.

       

      So it may just be that my library has given me a glitchy ACSM file. But since the file is apparently a protected EPUB document, not an open one, it may also be that iBooks can't open it at all. It also occurs to me that something I did has caused the ACSM file to become corrupt. (I did download the ACSM again, with the same results as above, on all steps.)

       

      In case it matters: I have been using Overdrive on my iPad to read books from my local library. I haven't tried to open this EPUB book in Overdrive on the iPad yet, because I don't have the iPad with me at the moment.

       

      Any suggestions you can give would be welcome.