2 Replies Latest reply on Dec 29, 2014 2:56 PM by chmpjf

    New Installation...Help needed!

    chmpjf

      I just installed a boxed version of Lightroom 5.  It immediately indicated the need for an update to which I agreed.  It told me to hit the import button and then a msg came up saying "Please select a source."  I am new to Lightroom, so I have no clue what it is asking me to do!