0 Replies Latest reply on Jan 7, 2015 9:59 AM by photoshop6691

    I have had Photo Shop 7.0 on my G4 computer for years, it was registered. Just purchased a used IMAC 10.6.8. when loading my PS 7.0 get warning that 10.6.8 will not support it??? Could I SOMEHOW still use my registered PS 7.0???

    photoshop6691

      I have always enjoyed my Photo Shop 7.0. Now can I somehow still use that version, 7.0 on my IMAC 10.6.8?

      Hate to spend hundreds of dollars on newer version.

      Don't need latest and greatest version.... 7.0 is just fine with me.