9 Replies Latest reply on Mar 21, 2015 11:57 PM by mgoetzke

    LR problem with external editing

    Viennaslim

      Hi, I have seen some posts with similar problems online but have not found an answer yet:

      I am using LR 5 and frequently edit pictures in Photoshop CS5 via the "edit in...CS5" command. ALWAYS in the past a dialog box used to open, asking me if I want to edit the original, a copy, or a copy with LR adjustments.
      All of a sudden, this dialog box does not come up anymore! The picture that opens in CS5 seems to have all LR edits, as far as I can tell, EXCEPT for some (but apparently not all!) spot removal edits. How is that possible?

      To make things even more confusing, for some of my pics the dialog box will still come up (every time), for the majority it won't (ever).

      The file format of the picture does not seem to be a factor, I did not detect a pattern there as far as behavioral differences between NEF and TIFF files.

      I have not updated the software or otherwise changed any settings in any way in a while before this started to happen.

      Just now I tried "reset all warning dialogs" in the preferences -makes no difference.

      Has anybody experienced this problem before, or knows of a solution?

      I have found similar posts (but no solutions) online with people having the same dialog box issues, but losing the cropping only. My cropping seems to carry over ok to CS5.

      Thanks!

        • 1. Re: LR problem with external editing
          JimHess Adobe Community Professional & MVP

          It has been along time since I have had access to Photoshop CS5. I cannot remember. But did Camera Raw in Photoshop CS5 have spot removal features. If it didn't, then that would explain why your spot removal wouldn't carry through if a TIF file wasn't created initially.

           

          The only reason I can think of that you wouldn't get the message asking whether to create the TIF file is if you checked the "don't ask again" Box.

          • 2. Re: LR problem with external editing
            Viennaslim Level 1

            Thanks, CS5 does have spot removal, but either way there was never a conflict in the past. Everything worked fine until 2 days ago. And this particular message does not have a "don't ask again" box.

            In the meantime I have tried to "edit in" other programs and the dialog comes up every time, with any photo. Which makes me think the problem may actually be on the Photoshop side of the combination.

            • 3. Re: LR problem with external editing
              JimHess Adobe Community Professional & MVP

              Are you using Lightroom 5.7.1 (the most recent release)? If not, I would suggest updating. And another thing you might try would be to delete your preferences file and let Lightroom create a new one.

              Preference and other file locations in Lightroom 5

              • 4. Re: LR problem with external editing
                Viennaslim Level 1

                Ok, since the problem only occurs when editing in Photoshop, I re-installed CS5 now (which was quite a hassle and took me hours, since apparently Adobe does not support it anymore!). This did not solve my problem. So, back to the drawing board...
                Jim, yes, I got the latest Lightroom 5 version. Lightroom would create a new preferences file if I deleted it? are you sure? what do I have to do for that to happen?

                I'm a little scared to mess things up worse than they are now, since I'm in the middle of a project that I need to finish. I could just keep on going with a workaround for now...(like exporting as a TIFF before editing it in CS5)

                Thanks

                • 5. Re: LR problem with external editing
                  JimHess Adobe Community Professional & MVP

                  Deleting the preferences file or renaming it slightly if that makes you feel more secure (just in case you feel you need to go back to it by renaming it back) will simply force Lightroom to create a new preferences file as soon as you start Lightroom. If you aren't confident in doing that then go ahead and finish your project with your current setup. You tried resetting all warnings, and that didn't work. The next choice is to delete or rename the preferences file so that Lightroom can create a new one. The preference file you are using now wasn't on your installation disk. It was created when Lightroom first started because the file didn't exist. Lightroom checks for that file every time it starts. If it isn't there then Lightroom creates it. But again, if you're not confident doing that then deal with the problem the best you can.

                  • 6. Re: LR problem with external editing
                    Viennaslim Level 1

                    ok, I tried that, but didn't like what happened and aborted the whole thing!
                    After making me register my LR version again, LR opened but didn't have any catalogs. so I just changed it back to the old preferences file. I'm a burnt child with temporarily losing catalogs and was only able to recover them in a lengthy process with help from somebody on this forum. I'd rather deal with a workaround for the rest of my life than go through this again...

                    • 7. Re: LR problem with external editing
                      JimHess Adobe Community Professional & MVP

                      Well, I'm sorry that didn't work for you. I wish you well. I don't have any other ideas. I have never been in a situation where I needed to delete the preferences.

                      • 8. Re: LR problem with external editing
                        Viennaslim Level 1

                        Jim, thanks for your help anyway! Maybe when I'm done with my project in a couple of weeks I might try to deal with this issue again. I just can't risk any further delay at this point.

                        • 9. Re: LR problem with external editing
                          mgoetzke

                          I have the exact same issue It stopped working in the middle of an editing session. It still works for onone plugins, but not for photoshop (cc). this is a serious impediment of my workflow. first i thought i had accidentally checked something in the previous dialog, but i reset all warnings but still.

                           

                          i cannot work like this. exporting each file manually to tif, re-synchroniying the folder, reapplying flags,etc. it takes just too log and is error prone.