2 Replies Latest reply on Nov 9, 2015 1:46 AM by PG de Jonge

    Dynamic Link Error: Source is empty.

    Jim Curtis Level 3

      This is an error I'm frequently getting when dragging Sequences over to Adobe Media Encoder.  The error is false, because all my Sequences have media in them.

       

      I have a couple of projects ongoing.  One has 7 sequences, another has 30.  I'm getting the error randomly; some Sequences travel over to AME fine, and others give me the error. 

       

      I've deleted prefs for both Pr and AME, rebooted, etc. and I still the issue persists.   Sometimes, I'll drag the same Sequence to AME a second time, and it will transfer over with no error.

       

      The issue is forcing me to export directly from Pr as a workaround.  Sequences export without issue this way.

       

      BTW, there's a pref in AME: "Import Sequences Natively" that when CHECKED, decides on its own to ignore in-outs and render only part of sequences.  So, I always leave that unchecked, which uses Dynamic Link.  Soo... this could be a Dynamic Link bug, I suppose.

       

      Has anybody seen this and know of a fix?

       

      Mac 10.8.5 - nVidia Quadro K5000 - most current versions of Pr (8.2.0 (65)) and AME (8.2.0.54)

        • 1. Re: Dynamic Link Error: Source is empty.
          Jim Curtis Level 3

          To add to what I posted, I just tried quitting and relaunching both Pr and AME, and was able to drag Sequences to AME and some that gave me the error were now dragging over without error.

           

          I also noticed something that is either a serious bug or just a major WTF in the programming:  When I drag a Sequence to AME, the name of my Pr project changes to the temp file name for the cache that Dynamic Link uses.  This is AWFUL.  I might save over that cache file project, and then when I go to AME to use the plus button to add a Sequence from what I THOUGHT was the current version of my project it's in a previously saved, and not current state.  THIS IS BAD.  Adobe, please fix this so that my Pr Project doesn't rename itself when I drag a Sequence to AME!


          I have also learned that if I get the error when dragging my Sequence from Pr, and try using the Plus sign in AME to load the same sequence, I don't get the error message, and the Sequence exports/renders properly.   I'm concluding that this is a bug.

          • 2. Re: Dynamic Link Error: Source is empty.
            PG de Jonge

            Same problem here, except I can't import any sequences and get that error message. And quitting and restarting haven't solved anything. I now need to sit here and export multiple versions of the same video one by one.