1 Reply Latest reply on Jan 9, 2015 12:12 PM by A.T. Romano

    Video clip previews won't play.

    adelante

      Videos won't play in Adobe Premiere Elements 10, but play fine in other programs on my computer. I've tried rendering it, installing a new hard drive for scratch disk, and saving the file in different locations. Once when I applied video merge to a clip, it played. I am editing videos blindly and can't take advantage of most of the features of the program. It's really frustrating. Any ideas?

        • 1. Re: Video clip previews won't play.
          A.T. Romano Level 7

          adelante

           

          What is the video card/graphics card that your computer with Premiere Elements 10 uses?

           

          If it is NVIDIA GeForce, then you have the well known and documented Premiere Elements 10/NVIDIA GeForce issue which is remedied by rolling back

          the driver version to about May 2013. Please review the following

          ATR Premiere Elements Troubleshooting: PE10: NVIDIA Video Card Driver Roll Back

          as well as  the Announcement on this matter at the top of this forum.

           

          Basically you will need to plug your information into the following NVIDIA fields to determine if there is a driver version for your card that is old enough to be used.

          NVIDIA Driver Downloads - Advanced Search

           

          If you are a Windows 8 or 8.1 64 bit user, you will probably find that old enough drivers do not exist for you. Then non NVIDIA GeForce card or Premiere Elements 11, 12, or 13.

           

          Please review and consider if any of the above applies to you. If not, then we will explore alternative troubleshooting.

           

          Thank you.

           

          ATR