3 Replies Latest reply on Jan 11, 2015 6:55 PM by johnt53984649

    Multiple Adobe Applications "Missing" Display Driver

    johnt53984649 Level 2

      am now using the following system configuration:

      • 2 NVIDIA GeForce GTX 970s
      • 5960X CPU
      • 2 850 Pro SSD drives
      • 32 GB DDR4 RAM
      • MSI Gaming 7 Motherboard
      • Windows 8.1 Pro (with ALL of the most recent updates)

      A list of my currently installed applications can be seen here:mzCHvyB.png1

      I am having problems with 4 utterly crucial applications:Photoshop, Premiere Pro, SpeedGrade and After Effects.  They were just installed last night; they are the most recent version.Here are the error messages that I am receiving for each program: Photoshop "detected an error in [my] display driver" and won't allow me to use any 3D options or even the either of the graphics cards.

      aKXuJvn.png2

      Premiere Pro won't even enter the workspace and gives me the following error message:  "Adobe Premiere Pro could not find any capable video play modules.  Please update your video display drivers and start again."  After this message it crashes.oahSmi4.jpg39xv6hsG.png4


      SpeedGrade won't even launch whenever I try to open it.  The cursor begins to spin as if it's doing something and then quits.  I've tried opening it several times, even with Administrator Permissions, but to no avail.  It just won't open at all and doesn't even bring up the entry loading screen. After Effects is a whole heap of trouble, with three error messages coming up:Firstly, "After Effects crashed previously attempting to initialize OpenGL.  Consult the manufacturer of your graphics card for a compatible OpenGL driver."

      fzVp1nL.png5 Which is followed by:tvOkAWT.png6 and then continued by: NvKANh8.png7

      After this, After Effects completely crashes and refuses to open (giving the same error message as seen in picture 4). I've got the crazy notion that it has something to do with my video card drivers (sarcasm).  Every message seems to have something to do with the graphics card, and SpeedGrade is the only thing that I can't be sure of since it doesn't even begin to start up whenever I try to open it. However, here's the catch; I have no idea what.  Just now, I manually uninstalled all of my graphics card drivers and did a clean re-install of the newest NVIDIA GTX 970 drivers from here: NVIDIA DRIVERS GeForce Game Ready Driver WHQL So I have the most updated drivers and most updated adobe software, and certainly have hardware that it's capable of using.  I'm not sure what the issue is here. Another thing that I would like to mention is that, when opening the NVIDIA control panel, I only have the following options:R9HoeIo.png8IZXONeG.png9

      I recall that, on other, older computers that I've used with NVIDIA cards and the NVIDIA control panel, there were many other otptions, such as the ability to control SLI and change 3D settings and whatnot.  None of that exists here, and I can't even enable stereoscopic 3D.  In fact, whenever I try to change anything in my extremely limited control panel, I just get the message shown in picture 9: "To use this feature, set the color depth to at least 32-bit." Alright, to sum it all up once and for all:

      • I'm assuming the problem that all of these applications are having has something to do with the NVIDIA GTX 970 cards
      • Even with the most updated software, the problem still exists.
      • A list of all my programs was given in case any of them might, possibly, be interfering with Adobe.
      • This computer is brand-new, basically, and the SSD drives are all quite empty.
      • I am running 4 displays, 3 of which on the same GTX 970 and another using this product: JUA310 USB 3.0 VGA Display Adapter

       

      Don't ask why I'm using that J5create product mentioned above, but I'll tell you that I have a feeling that it could, possibly, be interfering considering that it is basically its own graphics driver.  I have means to support this display without using it, however, so please mention if I need to stop using it for troubleshooting or because it could be the source of the problems.  Also, the other adobe applications seem to be working fine at the moment, but if they do ever have any problems, I might assume them to be caused by the same thing that's messing up all of these programs.

       

      So what should I do?!?

        • 1. Re: Multiple Adobe Applications "Missing" Display Driver
          JEShort01 Level 4

          The JUA310 has issues with Windows 8.1, I would suggest that you remove it and any related drivers from your system.

          • 2. Re: Multiple Adobe Applications "Missing" Display Driver
            johnt53984649 Level 2

            Okay, I will try that.  However, in the meantime, is there anything else anybody can think of that might be causing the problem?  I noticed that "3D Options" (where you choose what program uses what graphics card, whether or not the cards use SLI, etc) doesn't show up in the NVIDIA control panel, and it makes me feel as if the graphics cards aren't being fully recognized or something.  I suppose that the JUA310 could also cause that, but I really don't know.

             

            If anybody knows of anything else that could possibly be causing these graphics cards not to be fully recognized by the system, I'm willing to listen as well.  I will leave another reply once I've uninstalled the JUA310 driver.

            • 3. Re: Multiple Adobe Applications "Missing" Display Driver
              johnt53984649 Level 2

              Believe it or not, that was exactly the issue.  I uninstalled it and it fixed absolutely everything.  Every program works great now.  However, I am having one other problem, and it's one that I've seen that several other people have as well:

               

              Whenever I use SpeedGrade, it says that the GPU acceleration is disabled and I cannot use it without restarting the application.  This error occurs both with Dynamic Link and also just by opening up Speedgrade normally.  I'm unsure of how to fix that, but I'm assuming, as most other people are, that it's a bug with the newest version.  Perhaps I'll just install a previous version, which I could actually use some assitance with:

               

              Where can I install the previous versions of Adobe SpeedGrade CC 2014?  The creative cloud download manager is not an option to me for other reasons.  Is there any other way to download the next to most recent version of Adobe Speedgrade?