16 Replies Latest reply on Jan 19, 2015 2:37 PM by Townie64

    Removing borders

    Townie64

      Hi - I am new to Id and am using Id 9.2 on a Mac

      I am having troubles removing a border (that might not be the correct terminology) I have read many forums all suggesting these are borders - or margins - or columns and am getting nowhere. After playing with multiple settings (why not deepen the mystery ?) this border has returned to magenta along the top and a sort of brownish colour down the sides. If I use the selector tool it turns thicker blue. Despite much advice that this won't show on the final product, it is printing and showing up on PDF.

      I have tried altering view settings - screen mode - grids and guides - minimised margins to zero to no avail.

      Any ideas on how to get rid of this?

       

      Many thanks

      Screen Shot 2015-01-14 at 11.11.51 am.jpg

        • 1. Re: Removing borders
          Peter Spier Most Valuable Participant (Moderator)

          Perhaps you have a stroke applied to the frame.

          • 2. Re: Removing borders
            Townie64 Level 1

            Hi Peter

            Thanks for that. How would I know if it were the issue?  Ive found 'stroke' but when I click it, nothing is operable and I get a black and white no entry symbol when I click on the join icons.

            Thanks

            Chris

            • 3. Re: Removing borders
              [Jongware] Most Valuable Participant

              Basic sanity checks:

               

              Is the border a stroke applied to your image or not? You are misunderstanding basic InDesign operations. "I've found stroke [..] but nothing happens": you found the stroke panel, and it reflects the settings of the currently selected object. If you don't have an object selected (in this case, your troublesome image), you can click away at will and nothing will happen. (Also, the Join icons are for specifying the corner type. That is not relevant to your problem.)

               

              Is the border in your image or not? If so, moving the image will move the "borders" along as well. Solution: crop the border off or edit your image. (It's impossible to see in your screenshot if the text and lines are added inside InDesign or not. Exact instructions cannot be provided without information on how the image was created and inserted into your document. InDesign itself is helpful and forthcoming, but some of its users have workflow so bad that you cannot easily edit them anymore.)

               

              Are these InDesign guidelines? If so, switching to Preview Mode ought to hide them, and there is nothing else to do. (Some people seem to have a problem with guidelines, the pasteboard, and the black page outline that InDesign shows by default. Then again, some people cannot be helped.)

               

              If these are indeed guidelines and you get them in your PDF ... check your PDF Export Settings! There is a checkbox for including Visible Guides and Guidelines, and while this can be abused to easily insert horizontal and vertical lines in your document, it is not its primary function, and you should always have this switched OFF.

              • 4. Re: Removing borders
                Townie64 Level 1

                Thanks for your reply.

                I am a complete novice to Indesign and using under duress, so imagine my workflow is appalling - I'm just going step at a time and looking online each time I get stuck.

                 

                The image with the border is the map of Australia that was 'placed' to the 1st layer (base layer) I created - I can't remember now if this was as a PDF or JPEG. After I placed it, I dragged it to fill as much of the working area as possible. But I don't yet understand the terminology (pasteboard - guide - stroke etc) so am possibly doomed until I get some training.  If I try and delete the border, the image goes with it. I have then added multiple layers with different labels and text, so if I drag the border of the base layer to enlarge or resize, the subsequent layers and text are then obviously out of place.

                Changing screen mode settings between preview, normal, slug etc doesn't eliminate the problem.

                 

                Grateful for any help

                Chris

                • 5. Re: Removing borders
                  Townie64 Level 1

                  by the way - her is a closer image of the border when selected

                   

                  Screen Shot 2015-01-19 at 12.06.16 pm.jpg

                  • 6. Re: Removing borders
                    Ellis home Level 4

                    With the "border" selected go to Window/Stroke. Do you see a number in Weight? If that's the case put it back to zero.

                    • 7. Re: Removing borders
                      Townie64 Level 1

                      Hi Ellis

                      that didn't work unfortunately - I'm stumped.

                      Thanks anyway - any ideas welcome

                      • 8. Re: Removing borders
                        Peter Spier Most Valuable Participant (Moderator)

                        I'm a bit suspicious that the "border" you are seeing is actually the margin guides in this case and that your image frame is snapped to the guides so it looks like it's part of the frame. With no text cursor active, press the W key to go into Preview mode. Does the border disappear? If yes, it's a guide and nothing to worry about. If no, it's a stroke on a frame, and Ellis' suggestion should work, so maybe there is a second frame on the page to which the stroke is applied.

                         

                        Press the W key again to return to normal view. If the stroke is not the margin guide, please open the Layers panel (Window > Layers) and press the little triangle next to each layer name to expand the layer, then give us a screen shot of the panel.

                        • 9. Re: Removing borders
                          Townie64 Level 1

                          Hi again Peter

                          It didn't disappear with W key

                           

                          The only way to get it to disappear is to hide the layer (called map).

                          Here are 2 screen shots of entire length of the map layerScreen Shot 2015-01-20 at 5.30.51 am.jpg

                           

                          Screen Shot 2015-01-20 at 5.30.02 am.jpg

                          Thanks

                          Chris

                          • 10. Re: Removing borders
                            Peter Spier Most Valuable Participant (Moderator)

                            In the second scree cap, under the Map heading the 13th object is a <rectangle>. What happens if you click the eyeball next to it to hide it?

                            • 11. Re: Removing borders
                              Townie64 Level 1

                              Peter

                              That is just a separate small rectangle - Somehow 2 symbols I used (those small cyan dots) seems locked so I used the rectangle in white to hide them.

                              Thanks

                              • 12. Re: Removing borders
                                Peter Spier Most Valuable Participant (Moderator)

                                We could spend days guessing here. Can you share the file? I'll send you an upload link.

                                • 13. Re: Removing borders
                                  Peter Spier Most Valuable Participant (Moderator)

                                  I've got the file (would have been good to have the linked map, too to confirm, but it looks like the border is actually a part of the map graphic. if you use the Select tool (black arrow) you can move the frame bounds inward slightly and crop it off -- grab the center handle on each edge of the selection bounding box by clicking it and holding down the mouse, then drag towards the center.

                                   

                                  Or in the alternative you can select the frame, then go to the Control panel and click the center spot on the Transform Proxy (the group of 9 spots on the left end of the panel that looks like the bounding box of a selected frame, then click the chain link next to the height and width fields to make it unbroken, and finally, in either the height or width field click the cursor at the end of the current dimension and type -p5, then press Enter. That should be enough to remove the border, I think, and not enough to cut into the map.

                                   

                                  That frame also has a magenta fill applied, which you don't need. You set the fill on the frame to none.

                                  • 14. Re: Removing borders
                                    Townie64 Level 1

                                    Hi Peter

                                    it worked ... but I'm not sure which bit worked !

                                    The bounding box is still on the screen - but when I export to PDF it is no longer visible when all other attempts to do this it showed up.

                                    Thanks so much for your help - very much appreciated

                                    Chris

                                    • 15. Re: Removing borders
                                      Peter Spier Most Valuable Participant (Moderator)

                                      All objects will have a bounding box when selected, and you'll see the frame edges by default in normal mode, unless you hide them. That box itself does not print, but you can choose to apply a stroke to the frame, which will print.

                                       

                                      I suspect you'd probably benefit a good deal from buying a copy of Sandee Cohen's Visual QuickStart Guide to InDesign, the most recommended beginner's text here on the forum.

                                      • 16. Re: Removing borders
                                        Townie64 Level 1

                                        Just bought the E book version

                                        Thanks again

                                        Chris