2 Replies Latest reply on Jan 13, 2015 8:03 PM by JJMack

    With CS5, I am unabe to download Camera Raw 7.1 needed for my Canon 650D (Rebel T41).  Is there a way to accomplish that?

    sylviar54795607

      Is it true that Camera Raw 7.1 and higher versions are only compatible with CC, not with CS 5?