4 Replies Latest reply on Jul 16, 2008 1:21 PM by shenry

    CFGRIDUPDATE not working properly

    bfinelsen Level 1
      I am new to using the CFGRID tag and I think it's quite wonderful. However, I am having an issue with getting it to update a record. I am simply doing a simple query with the the selectmode="Edit". I can insert and delete with no problems, works fine. If I try to just update a record and then click submit, the data does not update. I receive no error, just no correct update. Any ideas as to why this is happening? I am using the applet version, not flash and I'm running this on CFMX 7.02. Thanks in advance for any help.
        • 1. Re: CFGRIDUPDATE not working properly
          tzimmerman Level 1
          I've tested this in CFMX 7.0.0, 7.0.2 and 7.0.2 with chf7020001 and it works fine in the first two cases. You have to make sure you tab out of the field before submitting the form. One thing I noticed is that if you shorten the number of characters in the value your editing it will update, but if you try adding characters it won't update unless you tab out of the field.

          I did see a problem when using 7.0.2 with chf7020001. When you submit the form you get the following error, but the database is updated:

          Error casting an object of type to an incompatible type. This usually indicates a programming error in Java, although it could also mean you have tried to use a foreign object in a different way than it was designed.

          I've submitted product issue 67192 for this problem.

          Ted Zimmerman
          • 2. Re: CFGRIDUPDATE not working properly
            Itisme38
            Any word on a fix for this problem coming anytime soon???

            I get the exact error you mentioned.

            Thanks.
            • 3. Re: CFGRIDUPDATE not working properly
              RJWilson40
              I get the same error, on a simple cfgrid with the cfgridupdate. I can do inserts and deletes all day long, but any edits are lost, no error, it acts like all is fine, but the edits do not take.

              I have a 7.0.1 test server and a 7.0.2 production as well as a just downloaded 7.0.2 developer machine on my notebook that all have the same problem using cfgridupdate.

              Adobe - tzimmerman, is there any news on a fix for this.
              • 4. Re: CFGRIDUPDATE not working properly
                shenry Level 1
                I'd like to know this as well.