1 Reply Latest reply on Jan 16, 2015 4:16 AM by vishu#13

    CF10 Update 14/15 No longer respecting noProxyHosts in jvm.config

    jamesallisonjr

      Hello,

       

      I have an instance of CF10 running behind a proxy server.  For the CF Admin to be able to get CF Updates, I had to add this line to the JVM Arguments.

       

      -Dhttp.proxyHost=xxx.xxx.xxx.xxx

      -Dhttp.proxyPort=xxxx

       

      That worked fine.  For my scheduled tasks to work locally I needed to add the following line.

       

      -Dhttp.noProxyHosts="localhost|127.0.0.1|10.*.*.*"

       

      That worked fine for 2 years as well as after all the updates.  This past weekend I applied Updates 14 & 15.  After the updates (which I manually executed) it seems like the JVM is no longer respecting the noProxyHosts entries.  I have a scheduled task that points to:

       

      http://localhost/fileToExecute.cfm

       

      Before the updates, this worked as expected.  After the updates, all I get is a message from the proxy server telling me this site is forbidden.  Don't get to hung up on the message from the proxy server.  It is a government public webserver and we use a proxy server to control access to the internet and if the site is not on a white list, you can't get out to the internet.  So I messed around with different variations of the JVM Arguments, but none seems to remedy the situation.  I have since just removed the three arguments.  This allows my scheduled task to run but now I won't be able to check for CF updates. I can live with that since I do manual updates anyway now, but still.... something has changed.

       

      I looked at the backed up jvm.config files after the previous updates.  They were all the same.  I noticed the current jvm.config has much more whitespace it it... seems to be formatted for humans to read now instead of minimized.  I tried to take an older jvm.config (same settings) and replace as the current (and restart CF service) but no change in behavior.  It really seems to me that Update 14 or 15 (I did both in a row) really changed how CF/JVM is dealing with proxy.

       

      Any insight?

       

      Thank you

       

      Jim Allison