4 Replies Latest reply on Jan 16, 2015 2:33 PM by Peter Spier

    Problem opening my own file

    artmanjs

      I have Adobe CS5, version 7. I have not had any problems creating files. I went to open one of my personal files and it is now telling me that I cannot open it as I need updated plugins.  Why would I need updated plugins if I was the originator of the file?  I s there someone I can speak to on this? Am I going to have to buy the new version of Adobe?