4 Replies Latest reply on Nov 23, 2016 6:10 AM by devashishk2527045

    Flash ESR 13.0.0.260 ActiveX msi package broken!

    mircod98601700 Level 1

      Hello,

       

      the newest version of the Flash ESR msi for IE (install_flash_player_13_active_x.msi) seems to be broken.

      I wasn't able to deploy it via GPO, nor to install it manually. It always fails with the error below.

      Older versions and the plugin-version don't have this problem.


      I also tried to manually start the "InstallAX_13_0_0_260.exe" extracted into the temp folder, but that one also fails with a message telling

      me s.th. like: You are trying to install an outdated version.


      Btw, I have no problem deploying the following msi packages on the same machine:

      Flash ESR 13.0.0.260 Plugin (install_flash_player_13_plugin.msi)
      Flash ESR 13.0.0.259 ActiveX (install_flash_player_13_active_x.msi)

      Flash 16.0.0.257 ActiveX (install_flash_player_16_active_x.msi)

      Flash 16.0.0.257 Plugin (install_flash_player_16_plugin.msi)


       

      OS: Win7 x86, fully updated

      Browser: IE11

      Flash: 13.0.0.260 ESR ActiveX msi

      Error log (excerpt):

       

      MSI (s) (B8:C8) [19:32:29:640]: Executing op: FileCopy(SourceName=FP_AX_~1.EXE|InstallAX_13_0_0_260.exe,SourceCabKey=InstallAX_13_0_0_2 60.exe,DestName=InstallAX_13_0_0_260.exe,Attributes=16384,FileSize=17381040,PerTick=65536, ,VerifyMedia=1,,,,,CheckCRC=0,Version=65535.0.0.0,Language=1033,InstallMode=58982400,,,,,, ,)

      MSI (s) (B8:C8) [19:32:29:640]: File: C:\Users\XXX\AppData\Local\Temp\InstallAX_13_0_0_260.exe; To be installed; Won't patch; No existing file

      MSI (s) (B8:C8) [19:32:29:640]: Source for file 'InstallAX_13_0_0_260.exe' is compressed

      InstallFiles: File: InstallAX_13_0_0_260.exe,  Directory: C:\Users\XXX\AppData\Local\Temp\,  Size: 17381040

      MSI (s) (B8:C8) [19:32:29:759]: Executing op: CacheSizeFlush(,)

      MSI (s) (B8:C8) [19:32:29:759]: Executing op: ActionStart(Name=NewCustomAction1,,)

      Action 19:32:29: NewCustomAction1.

      MSI (s) (B8:C8) [19:32:29:762]: Executing op: CustomActionSchedule(Action=NewCustomAction1,ActionType=3090,Source=C:\Users\XXX\AppData\ Local\Temp\InstallAX_13_0_0_260.exe,Target=-install -msi,)

      CustomAction NewCustomAction1 returned actual error code 1013 (note this may not be 100% accurate if translation happened inside sandbox)

      MSI (s) (B8:C8) [19:32:30:539]: Note: 1: 1722 2: NewCustomAction1 3: C:\Users\XXX\AppData\Local\Temp\InstallAX_13_0_0_260.exe 4: -install -msi

      Info 2835.The control ErrorIcon was not found on dialog SetupError.

      Error 1722.There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action NewCustomAction1, location: C:\Users\XXX\AppData\Local\Temp\InstallAX_13_0_0_260.exe, command: -install -msi

        • 1. Re: Flash ESR 13.0.0.260 ActiveX msi package broken!
          mircod98601700 Level 1

          Still no solution! Please don't keep ESR-users hanging w/o the current security patches.

          • 2. Re: Flash ESR 13.0.0.260 ActiveX msi package broken!
            mircod98601700 Level 1

            The new Flash ESR 13.0.0.262 ActiveX msi package is broken, too. It behaves exactly as I described above for version 13.0.0.260.

             

            The following msi packages install fine on the same machine:

            Flash ESR 13.0.0.262 Plugin msi (install_flash_player_13_plugin.msi)
            Flash ESR 13.0.0.259 ActiveX msi (install_flash_player_13_active_x.msi)

            Flash 16.0.0.257 ActiveX msi (install_flash_player_16_active_x.msi)

            Flash 16.0.0.257 Plugin msi (install_flash_player_16_plugin.msi)


            Only the two most recent ESR ActiveX msi packages 13.0.0.260 and 13.0.0.262 (both released in January 2015) cannot be installed.

            • 3. Re: Flash ESR 13.0.0.260 ActiveX msi package broken!
              mircod98601700 Level 1

              I finally found out what the problem was and I also have a workaround:

               

              The problem manifests itself only when on the machines one of the most recent non-ESR Versions (16.x) had been installed before (a "virgin" machine is not affected).

              These packages leave a registry-key behind even after deinstallation, which prevents a future Installation of the most recent ESR versions 13.0.0.260 and later.

              This key or better the values it contains mark all (supposedly) older versions, including the current ESR version, as unsafe and the installation fails (interestingly only the ActiveX msi seems to be affected).

               

              The problematic reg-key is "HKEY_LOCAL_MACHINE\SOFTWARE\Macromedia\FlashPlayer\SafeVersions" (and for Win x64 also "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Macromedia\FlashPlayer\SafeVersion").

              By deleting this key before installing / deploying the newest ESR msi the problem vanishes. Reg-keys can be deleted with a Group policy.

               

              Nonetheless, it would be nice if Adobe could change the behavior of the 16.0.0.x msi-packages in the future so that the newest ESR-version is also considered safe to install.

              1 person found this helpful
              • 4. Re: Flash ESR 13.0.0.260 ActiveX msi package broken!
                devashishk2527045

                great help!!! it resolved my issue.. super happy!!