3 Replies Latest reply on Aug 4, 2016 1:48 PM by rubin110

    DNG Timestamp from Android camera2 API

    rocketman1222 Level 1

      Hey folks-

       

      I have a problem with erroneous timestamps on my DNG images coming from Android apps capable of capturing RAW images.

       

      I have been very excited that Android now allows RAW capture in the new camera2 API, in the form of DNG files.  I have a Nexus 6 and I have tried two paid apps that that allow DNG capture ("Camera FV-5" and "Manual Camera").  In both cases, when I import the DNG files into Lightroom, they are showing up in directories that are days in the past.  At first, I blamed FV-5, since it was completely rewritten around the new Android API.  But just today I tried Manual Camera, and it does the exact same thing.

       

      I've been in discussion with the FV-5 author, and poked around the API a bit, and it appears that the DNG comes straight from the camera.  If the timestamp is wrong, it seems like it is probably Android's fault.  However, when I take a DNG file directly from my phone's file system and examine it with exiftool, I see this (some info redacted):

       

      ExifTool Version Number         : 9.78

      File Name                       : IMG_20150107_153045.DNG

      Directory                       :

      File Size                       : 25 MB

      File Modification Date/Time     : 2015:01:07 15:30:47-07:00

      File Access Date/Time           : 2015:01:07 17:39:54-07:00

      File Creation Date/Time         : 2015:01:07 17:39:54-07:00

      File Permissions                : rw-rw-rw-

      File Type                       : DNG

      MIME Type                       : image/x-adobe-dng

      Exif Byte Order                 : Little-endian (Intel, II)

      Subfile Type                    : Full-resolution Image

      Image Width                     : 4208

      Image Height                    : 3120

      Bits Per Sample                 : 16

      Compression                     : Uncompressed

      Photometric Interpretation      : Color Filter Array

      Image Description               :

      Make                            : motorola

      Camera Model Name               : Nexus 6

      Strip Offsets                   : (Binary data 26769 bytes, use -b option to extract)

      Orientation                     : Horizontal (normal)

      Samples Per Pixel               : 1

      Rows Per Strip                  : 1

      Strip Byte Counts               : (Binary data 15599 bytes, use -b option to ext

      ract)

      X Resolution                    : 72

      Y Resolution                    : 72

      Planar Configuration            : Chunky

      Resolution Unit                 : inches

      Software                        : google/shamu/shamu:5.0.1/LRX22C/1602158:user/release-keys

      Modify Date                     : 2014:12:31 04:08:50


      The creation time that I have in bold at the top is absolutely correct.  But note this "modify date" at the bottom.  For whatever reason, that is the time that Lightroom is using to identify the file...putting it in dated folders according to that time, renaming the file with that YYYYMMDD_HHMMSS, and telling me that this is the capture time when I hover over the preview.

       

      So this is where my limited knowledge and expertise run out.  First of all...what is "Modify Date"?  How is it different from the formal "File Modification Date/Time"?  Why does Lightroom choose to use this instead of the aptly named "File Creation Date/Time" (perhaps a question for a Lightroom forum)?  And, of course, why is this time in the past (perhaps a question for the Android devs)?

       

      Any thoughts?  Has anyone else seen this?  I have searched around and found no trace of this issue anywhere, and I'm shocked that no one would be pairing Lightroom with Android DNG images and reporting this yet.

       

      Thanks!

      Drew