6 Replies Latest reply on Jan 23, 2015 5:18 AM by sandidolsak

    Time Remap controled with expression problem (bug?)

    sandidolsak

      Hello, I have a very situation with Time Remap and it I can't find a solution, here is the scenario:

       

      image: https://dl.dropboxusercontent.com/u/1564440/3D/time_remap_problem.jpg

       

      If you check the image:

      - the white line is animated from left to right (it is precomped)

      - red square is animated from 0% to 100% opacity, then time frozen and expression controlled - expression is simply sampling the precomp with white line passing, the point that is sampling is exactly under the red square

      - on frame 1, it samples black, that means time remap is 0 (on this frame red square is 0% opacity), and you can clearly see the red square!

      - frame 2, it samples white, time remap shows frame 98, and the result is correct

      - frame 3, it samples black, time remap shows frame 0, all good

       

      now if you compare frame 1 and 3, both sample black color, but the result is different although time remap value is 0, but this is not what the viewport is showing me.

       

      I tried searching around with no success, prerendering white line doesn't help.

       

      I would really appreciate help on this, this is only a part of a big setup, and the error is very visible :/

       

      Thanks,

       

      Sandi Dolšak

        • 1. Re: Time Remap controled with expression problem (bug?)
          Mylenium Most Valuable Participant

          There is nothing wrong. You are not converting your coordinates properly, hence a different area than the one you expect is being sampled. Especially with shape layers this can be extremely tricky due to the individual transforms of each group. Layer space transforms are your friend or write your own compensation code.

           

          Mylenium

          • 2. Re: Time Remap controled with expression problem (bug?)
            Rick Gerard Adobe Community Professional & MVP

            It would really help if we could see the properties of all layers involved. I don't know what the layer Luma is or what it does.

            Screen Shot 2015-01-22 at 11.18.53 AM.png

            I take it that you color sample the location of the point control and convert that to frames to drive the time remapping.

            Is the time remapped layer the red square? When you pre-composed did you move all attributes? What are the other properties of the red square layer?

             

            Your expression works just fine with this project. I only changed the max number of frames.

            Dropbox - bouncyThingie_CC.aep(Note: Dropbox will add a .txt expression to the .aep file. Just remove it to open the sample file)

            • 3. Re: Time Remap controled with expression problem (bug?)
              sandidolsak Level 1

              Thank you both for taking a look!

               

              Rick, you example is perfect, I edited it with that I described in main post, white line, and it happens again, I uploaded the modified file and here is a screenshot to make it clear what is not working.

               

              timeRemap_problem_02.png

              https://dl.dropboxusercontent.com/u/1564440/3D/bouncyThingie_CC_01.aep

               

              is it something I am doing wrong?

               

              Thanks again.

               

              Sandi Dolšak

              • 4. Re: Time Remap controled with expression problem (bug?)
                sandidolsak Level 1

                Well it turns out it has nothing to do with sampleImage, it is a pure Time Remap problem

                 

                if you remove the expression all together and simply keyframe Time Remap:

                frame 0 - value 0

                frame 1 - value 149

                frame 2 - value 0

                 

                it has the same problem, the result is the same for frames 0 and 1, both show frame internal frame 149...

                 

                This it totally unusable, does anyone know of an alternative or something, I wold really like to get this to work...

                 

                Thanks,

                 

                Sandi Dolšak

                • 5. Re: Time Remap controled with expression problem (bug?)
                  Rick Gerard Adobe Community Professional & MVP

                  I think you have found a bug. Set frame 0 to anything but 0 and it works or move the third keyframe to frame 3 and it works. I'm not sure what's going on mathematically but all it takes is a one frame separation. IOW, set the keyframes to 1, 149, 0 or 0, 149, 1, 0 and everything works.

                   

                  Here's the deal, at 29.97 or even 20 fps a single frame of the image popping in and out of a major position shift is not going to register with most audiences. If you really want the motion to jump then you have to enable hold keyframes.

                   

                  I'm not saying that this bug doesn't matter but I can't see a situation where it would be useful to stutter one frame for only one frame. This works just fine if you make the distance between keyframes 2 frames.

                  • 6. Re: Time Remap controled with expression problem (bug?)
                    sandidolsak Level 1

                    Rick, thanks for checking.

                     

                    The example I provided was a only a segment of my setup, I have a grid of rectangles 21x21, and if you imagine a vertical line traveling from left to right, the rectangles should "turn on" only when over a line, so this looks very wonky with this bug... this is just the situation where it goes really wrong and it is noticeable... so in this situation this bug matters.

                     

                    After trying to figure out a work around, I noticed this bug appears only when I am remapping a composition, not a footage, so I "solved" it by prerendering what is in the composition that I am remapping.

                     

                    But still, lost so much time for something so basic...

                     

                    Thanks again for your time,

                     

                    Cheers,

                     

                    Sandi Dolšak