3 Replies Latest reply on Jan 22, 2015 2:05 PM by thenaturalmama

    Preview Cache error causing LR to close

    thenaturalmama

      I'm getting the "Lightroom encountered an error when reading from its preview cache and needs to quit." message every time I open up Lightroom on my Mac. I've found several threads on here and elsewhere that said deleting the .lrdata file should fix the problem. I've done that and it hasn't helped. I've deleted my catalog, and every lightroom-related file I can find on my computer. I've uninstalled and then reinstalled Lightroom and still getting the error message. HELP! What else is there to do???

        • 1. Re: Preview Cache error causing LR to close
          JimHess Adobe Community Professional & MVP

          Deleting the catalog certainly didn't solve anything. That simply got rid of all the work you have done. Are you certain that you went to the folder containing your catalog and deleted the folder that had the extension .lrdata? It's a folder, not a file.Capture.JPG

          As you can see, I have several such folders. When you receive the error message that you have received, you need to delete the folder that has the same name as the catalog you are using, except for the extension.

          • 2. Re: Preview Cache error causing LR to close
            thenaturalmama Level 1

            Deleting the catalog was a last-ditch effort to get it to work as I read on another site that if deleting the preview cache doesn't work the catalog itself may be corrupted. It obviously didn't work, but I figured if I could get LR to even open, it would be worth rebuilding the catalog and/or trying to restore it from the backup on my external drive. I've searched my computer for .lrdata and nothing else has come up. It was just the one file which I deleted.

            • 3. Re: Preview Cache error causing LR to close
              thenaturalmama Level 1

              Deleting the catalog was a last-ditch effort to get it to work as I read on another site that if deleting the preview cache doesn't work the catalog itself may be corrupted. It obviously didn't work, but I figured if I could get LR to even open, it would be worth rebuilding the catalog and/or trying to restore it from the backup on my external drive. I've searched my computer for .lrdata and nothing else has come up. It was just the one file which I deleted.