7 Replies Latest reply on Mar 9, 2007 10:16 AM by Aeneas3

    Running JavaHelp Outside of RoboHelp

    Troy_Wells
      I am not new to RoboHelp, but normally I only generate web help and printed documents. I am now trying to generate JavaHelp for the first time. I can generate it and when it asks if I want to view what was generated, it comes up fine.

      If I need to send this to someone, however, I need to be able to view it by double-click an executible jar file, or the like. However, when I try to click on what appears to be the executible jar file, I get the message:

      Failed to load Main-Class manifest attribute from (path)\(filename).jar

      What is the proper way for me to open the javahelp outside of RoboHelp?

      Thanks!!
      Troy
        • 1. Re: Running JavaHelp Outside of RoboHelp
          CraigCC Level 2
          Hi Troy,

          You need the javahelp viewer.

          Check out the topic 'Distributing JavaHelp' in the robohelps online help.

          Kind Regards
          Craig
          • 2. Re: Running JavaHelp Outside of RoboHelp
            maniac9999 Level 1
            Troy,

            For reviewers of our JavaHelp, I create a WebHelp version. Since they're only reviewing for content, this seems to work well.

            Jim

            • 3. Re: Running JavaHelp Outside of RoboHelp
              Troy_Wells Level 1
              I just loaded the latest JRE and rebooted, but that did not help. This help project was originally done in WebWorks for FrameMaker. The jar files created by WebWorks still work fine, but I still get the same error when I try to open the jar files created by RoboHelp.

              Any other ideas?

              Thanks!!
              Troy
              • 4. Re: Running JavaHelp Outside of RoboHelp
                Dave McGovern
                I haven't done more than experiment with JavaHelp, but the way I view the help files outside of the context of RH is to open the JavaHelp viewer and use browse to locate/open either the *.jar file (for compressed JavaHelp) or the *.hs (helpset) for uncompressed JH. There must be a way to make a .jar respond to double-clicking, but I don't know what it is.

                Hope this helps.
                • 5. Re: Running JavaHelp Outside of RoboHelp
                  Dave McGovern Level 1
                  Sorry, Troy...I just read the rest of the thread and see that my suggestion had already been mentioned.
                  • 6. Re: Running JavaHelp Outside of RoboHelp
                    Troy_Wells Level 1
                    I found a file in the jar file called:

                    .\meta-inf\Manifest.mf

                    In the jar file generated by WebWorks, this file has the following (NOTE the last line):

                    Manifest-Version: 1.0
                    Arguments: -helpset Contract_Composer_Help.hs
                    Run-Class: sunw.demo.jhdemo.JHLauncher
                    Class-Path: runjar.jar jh.jar hsviewer.jar
                    Created-By: 1.4.2_10 (Sun Microsystems Inc.)
                    Main-Class: com.webworks.runjar

                    However, the file generated by RoboHelp does not have this line. All it has is:

                    Manifest-Version: 1.0
                    Created-By: 1.4.2_10 (Sun Microsystems Inc.)

                    While I can't be sure, it seems this is my problem. Do you know how to get RoboHelp to generate the correct information in this file so that the error is eliminated?

                    Thanks!!
                    Troy
                    • 7. Re: Running JavaHelp Outside of RoboHelp
                      Aeneas3
                      Troy,

                      I use the JavaHelp 2.0 compressed with source files. My manifest.mf file reads:

                      Manifest-Version: 1.0
                      Created-By: 1.5.0_07 (Sun Microsystems Inc.)

                      and I have no problem viewing using the JavaHelp Viewer using Java(TM)2 Platform Standard Edition. Do you have the latest JavaHelpViewer because our creation builds appear to be different and mine works fine.

                      Out of curiosity, have you selected a JavaHelp 2.0 layout because there are know problems with JavaHelp 1.1.3 and RH.

                      Susan