3 Replies Latest reply on Jan 28, 2015 7:27 AM by vrjunkie

    ColdFusion Builder 3.0 Will Not Highlight Syntax

    vrjunkie

      Hi,

       

      I just installed ColdFusion Builder 3.0 and it will not do the syntax highliting on existing files - only if I type them in from scratch. Anybody have an ide whats going on?

        • 1. Re: ColdFusion Builder 3.0 Will Not Highlight Syntax
          robbart

          With Builder, I've found that when a file isn't highlighting syntax properly, its usually caused by some issue with the file... some syntax issue earlier in the file causes Builder to not update highlighting elsewhere until that issue is corrected.

           

          If you create a blank CF file, and start typing, does it provide a dropdown on available options on the CF tags as you type them?

           

          Is anything highlighted?  Red or otherwise?

          • 2. Re: ColdFusion Builder 3.0 Will Not Highlight Syntax
            Nathe_in_Appalachia

            I have the same problem with Builder 3 straight out of the gate.  I have code that is fine in Builder 2.  I won't use 3 until I hear how to fix this.

            • 3. Re: ColdFusion Builder 3.0 Will Not Highlight Syntax
              vrjunkie Level 1

              I have an update:

               

              It is due to the case of the file extension.

              I found out by accident that if I open a file ending in .cfm highlighting works. But If I open a file ensing in .CFM it does not. ALmost all of our files end in uppercase due to a long ago established naming convention.

               

              I tried adding .CFM to the file associations and it said it already existed.

               

              The I said, ok, lets remove it and add .CFM it took it but when I exited and came back it shows the extension in lowercase instead of the upper case I entered. Now neither case will show highlighting.

               

              So then I said, ok, lets remove it and add it back again as lower case as it originally installed as.

               

              Still it will not highlight either .cfm or .CFM.

               

              Clearly there is a bug here - any ideas anyone?