3 Replies Latest reply on Jan 28, 2015 2:21 AM by ukelady

    I have Adobe player/Flash version12007 &told to upgrade to13.00182?

    ukelady

      Have an olderX2 computer Am using Firefox as Browser, but Like Google the best for info. I don't need a lot of fancy stuff & don't watch many videos or make them. Also play few games. I don't need a higher version but keep getting warnings that I MUST upgrade in order to reach some Web sites.Warning states This plugin is vulnerable and should be upgraded. Then when I go to Firefox it tells me Firefox must be upgraded. I never had this problem until the last few months. I'm not an inovator but don't want to lose my limited use of the computer.. Lots seems tu be happening since Microsoft stopped supporting my X2 computer. Can anybody help me??Old Flash Player on Download Page