13 Replies Latest reply on Jul 28, 2015 6:29 PM by Amebr

    TOC caching issue on IE

    argus08

      Hello all

      RH10 to webhelp

      I just received a call from an ongoing client. He's reporting that they are experiencing TOC caching issues in IE only. A topic and a book in the TOC that we removed in the latest updates are still appearing in the TOC, but obviously are dead links to topics that no longer exist. He said they cleared the folder and replaced it entirely with the new output files. They clear the cache but they keep showing up. He says they don't have this issue in Chrome.

      Any ideas?

      Thanks,

      Laurie

        • 1. Re: TOC caching issue on IE
          Jeff_Coatsworth Adobe Community Professional & MVP

          Not much you can do to force a browser to dump its cache and refresh as far as I know.

          • 2. Re: TOC caching issue on IE
            KimberlyO Level 2

            It looks like there is a more thorough way to clear cache by using the developer tools in IE.  Maybe this might help??

            https://kb.wisc.edu/page.php?id=15141

            • 3. Re: TOC caching issue on IE
              argus08 Level 1

              He would ideally be looking for a way to not cache or to automatically clear the cache so his clients don't have to manually do it each time (they likely wouldn't know that they even would need to, and would just be confused by orphan links in the TOC).

              I found info re using meta tags to disable the cache (Disable Browser Caching with Meta HTML Tags [Cristian Sulea]). I inserted the tags into the master page header according to the instructions, but curiously they are not included in the output topics. I manually inserted it into the index.htm, and have sent the output to the client to test. I can't test it because I'm not experiencing the issue.

              • 4. Re: TOC caching issue on IE
                argus08 Level 1

                Just to close the loop (sort of) on this: I passed along the info to the client, as mentioned above. When I later followed up with him, he said that they had "decided not to worry about it. No end users have reported issue. It’s mostly new users who use the online help, and they wouldn’t experience any caching issues."

                • 5. Re: TOC caching issue on IE
                  Amebr Level 4

                  Speaking of meta tags, I discovered something interesting yesterday.

                   

                  If you paste the tags into the <head> tag of the master page, they don't show up in the output. If, however, you paste them into Robohelp's "header" area, they are automagically copied into the <head> tag and do show up in output.

                   

                  (I originally managed to get around the issue by including them in the screen layout (HTML5 Multiscreen) but this workaround is probably easier.)

                  • 6. Re: TOC caching issue on IE
                    argus08 Level 1

                    Thanks Amber, I'll try that for the next time I do updates for this client.

                    Laurie

                    • 7. Re: TOC caching issue on IE
                      DanielSandor

                      Hi Amebr,

                       

                      could you please help me with information on what you meant by 'Robohelp's "header" area'?

                       

                      I am experiencing the same problem as described here, but I'm not sure where to copy the tags in the project.

                       

                      Thank you,

                      Daniel

                      • 8. Re: TOC caching issue on IE
                        argus08 Level 1

                        Amebr, allow me 

                        Hi Daniel

                        Good timing, I just revisted this client project this week and implemented Amebr's suggestions, and they did indeed work.

                        1. In your master page, insert a header, if you don't already have one.
                        2. Open the HTML view of the master page.
                        3. Paste the three lines of meta tags below the <?rh-region_start type="header" line.
                        4. When you save, they will, as Amebr says, automagically move to the <head> area.
                        5. In your SSL, select to apply the master page to all topics, then generate your output. The tags will be in the <head> area of all topics.

                        meta tags in header.png

                        CAVEAT:

                        This resolved the problem of getting the meta tags into all topics - I don't know if it resolved the client's reported caching issue.

                         

                        Cheers,

                        Laurie

                        • 9. Re: TOC caching issue on IE
                          Amebr Level 4

                          Thanks Laurie. Looking back on my original post, I should have been clearer - I blame over-excitement because problem-solving.

                          • 10. Re: TOC caching issue on IE
                            DanielSandor Level 1

                            Dear Laurie,

                             

                            Thank you for your kind help!

                             

                            In a text editor, we copied the following lines to the .htt file (which is used by all topics as master page) after the <body> tag, just as you wrote:

                            <?rh-region_start type="header" ?>

                                <meta http-equiv="Cache-Control" content="no-cache, no-store, must-revalidate" />

                                <meta http-equiv="Pragma" content="no-cache" />

                                <meta http-equiv="Expires" content="-1" />

                            <?rh-region_end type="header" ?>

                             

                            After saving and generating the output, it does not move to the <head> area, and it does not appear in the <head> areas of the generated topics. We searched for the tag "no-cache" in the generated files, but none of them included this tag. We tried to add a new topic and it does not load in Internet Explorer, only if the cache is deleted manually.

                             

                            What do you mean by selecting to apply the master page to all topics in my SSL? Is it a menu, or a dialogue panel? How can I adjust its settings?

                             

                            Thank you in advance,

                            Daniel

                            • 11. Re: TOC caching issue on IE
                              Amebr Level 4

                              After you save, try switching to design view. This should cause the meta tags to move into the head section. You should be able to switch back into HTML to check that this is the case.

                               

                              I'm not in front of RH at the moment, but from memory you can assign the master page to individual topics, or you can select the master page in the SSL - it should just be a drop-down list you can select from. I think the only difference is that the first method means you can have multiple master pages and might miss assigning the master page to some topics, while the second method means the master page is applied to all topics in the project (and you can only use one at a time).

                              • 12. Re: TOC caching issue on IE
                                argus08 Level 1

                                I thought the issue might have been that Daniel made the change in an external text editor. I retested this to get screen shots, and now I'm getting different results.

                                Daniel, here's how I initially made the change:

                                1. In RH, open the master page and switch to HTML view to insert the tags as described above
                                  RH_edit_master_page.png
                                2. When you save the file, the tags move to the head section:
                                  RH_edit_master_page2.png
                                3. When you generate the output, in the SSL, select to apply the master page to all topics. (As Amebr noted, if you have multiple master pages, you won't do this, but will have to apply the appropriate master page to topics individually or via the Topic List.)
                                  RH_apply_master_page.png

                                CAVEAT #2 / appeal to Amebr:

                                When I first tried this, the meta tags were indeed applied to the head section of each topic. When I just ran through this process again however, they are not. They do appear in the topic further down, just not in the Head section (they are in the first Div between the scripts and the rest of the body). I don't know what changed, nor if meta tags work outside of the Head section.

                                • 13. Re: TOC caching issue on IE
                                  Amebr Level 4

                                  For caveat 2, it's entirely possible the behaviour changed in an update. I think I was on 11.01 at the time of my original post and now am on 11.0.4.

                                   

                                  I believe meta tags are invalid in the body in HTML4, so I wouldn't expect them to work (or at least not reliably).

                                   

                                  For webhelp, you might need to manually update the index page each time you generate - I did this many years ago, and because the file didn't change, we just kept a backup of that file and pasted it into the output directory after each compile; I haven't tried this recently though.

                                   

                                  Or modify the seed files in the Robohelp installation directory - but these will probably be overwritten each upgrade, so that's a risk you'd have to consider.

                                   

                                  Or contact Adobe and see if they can offer a solution - it's possible this is a bug.