8 Replies Latest reply on Feb 4, 2015 4:09 PM by Chris Cox

    Photoshop CC can't seem to handle complex/high poly count 3D Models. Will this be addressed?

    rr55950286

      Hello all,

       

      I am running Photoshop CC on 3 systems and having the relatively same problems on all. The source files are exported from ZBrush- .stl or .obj files that are complex and have high poly counts. The file sizes are into the hundreds of megabytes.  These are not the simple files like they show when people are using the 3D features- a racecar or simple toy rocket.

       

      Photoshop CC doesn't seem to be able to open all the files and even when it does, the structures facings or facets don't always appear correct. I've developed a partial workaround, by merging the objects and reducing the poly count (which creates a new set of problems).

       

      If I do get a file open, my ultimate goal is to be able to color it, add light it and render it for 2d print purposes. Again Photoshop seems to be picky- When I apply color via the airbrush tool, it usually isn't smooth. It seems to apply color by facet or facing. Same thing when I try to manually add in texture from another source file. It appears to make the detail jagged and blurry from the source file.

       

      The appeal of using Photoshop for this process is we have people here who can do it without too much of a learning curve. Otherwise everyone else has to learn ZBrush just to color and light the models.

       

      I've pretty much done all the troubleshooting I can and exhausted all the tools at hand. I have tried both texture painting and projections painting and all the other options. I believe the meshes are just too complicated. And if there is something incorrect in the file, such as a reversed normal, Photoshop doesn't seem to know how to deal with it. My systems have more than enough to handle the files.

       

      Does anyone have any similar issues and is Adobe working on them in the form of a new release?

       

      Thanks!