18 Replies Latest reply on Apr 3, 2017 7:42 AM by Nipun Asthana

    Brush tool creates (lagging) dots instead of strokes/lines 15% of the time

    Worksofheart Level 1

      Whenever I try to use my brush tool, it doesn't seem to register and only create a dot on the position where I first placed my brush, despite dragging my brush along the entire canvas. This happens around 10-15% of the time, the other times it creates a stroke normally.

      I am using a Wacom Intuos 3 and haven't got any issues (in the same moment) with brush strokes in Photoshop, or any other program for that matter. I do have the feeling that the issue is worse in the most recent version of Flash than the previous one. (CC/CC2014)

       

      It seems as if there is some system check that lags tablet input from registering in Flash correctly. It's breaking up my workflow and I could really use a fix. Anyone knows how to fix this?

       

      I use Windows 8.1, 8 Gigs of RAM.

        • 1. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
          Worksofheart Level 1

          No one? Adobe, is this a known issue? Not even any suggestions?

          • 2. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
            Preran Adobe Employee

            Hi Marlies,

             

            Which device are you on? Which OS?

             

            Thanks,

            Preran

            • 3. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
              Worksofheart Level 1

              As you can see in my original post, I'm on a PC, Windows 8.1. 64 bit

              AMD FX(tm)-8350 Eight-Core Processor 4.00 GHz

              8 Gigs of RAM

              No issues with Photoshop or any other program (at the same time, even).

              • 4. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                Preran Adobe Employee

                Hi Marlies,

                 

                Am asking around. Will let you know as soon as I have some more information on this one.

                 

                Thanks,

                Preran    

                • 5. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                  Mukesh R Shah Adobe Employee

                  hi Marlies,

                   

                  Can you please check the Wacom setting. Please change the mode to PEN mode. Flash does not support Wacom in Mouse mode.

                  Also please share the video of the issue you are facing.

                   

                  Rgds,

                  Mukesh

                  • 6. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                    Worksofheart Level 1

                    ...Is that a serious suggestion? No, I have NOT put my Wacom in a mouse setting. It has always been in Pen mode.

                     

                    - I use the Wacom Intuos 3 on a Pen setting always. Adobe Photoshop, Indesign or After Effects have NO issues with my Wacom whatsoever.

                    - I have installed and used the latest driver of the Wacom.

                    - Other Adobe programs, or any other program for that matter, has NO issues with my Wacom at all.

                    - I use a PC, Windows 8.1, 64 bit and an AMD FX(tm)-8350 Eight-Core Processor 4.00 GHz and 8 Gigs of RAM.


                    I have included a video of this happening, and I'll try to describe it one more time to give you as much information as I can.


                    Adobe Brushproblem - YouTube


                    When I am using the brush tool to draw an object, I drag my brush over the canvas to draw strokes.

                    To do that, I drag my Wacom pen across the tablet to create these strokes. (To clarify: I only draw strokes, never dots).

                    Normally, these strokes appear fine, as you can see in the beginning of the video, and towards the end.

                    However, at 3 seconds in the video, I want to create another stroke, but it doesn't appear. Even though I am dragging my Wacom pen/Flash brush across the entire canvas, but Flash doesn't seem to register any stroke at all.

                    The moment I release my Wacom pen from the tablet, Flash creates a small dot on the position where I first pressed my brush on the canvas. That's when you see the dot appear.


                    (After that I make a few new strokes to see if the bug comes up again, but it doesn't. You see it happening ONCE in this entire video.)


                    This happens around 10% of the time, sometimes worse, sometimes not.

                     


                    • 7. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                      sagasplayground Level 1

                      I'm sometimes experiencing this issue as well on a Cintiq 13HD, Flash Pro will once in a while just create a dot instead of the stroke I made (wouldn't quite value my experience at 10% of the time, more like a ones pr 30mins). That is on a iMac btw.

                      1 person found this helpful
                      • 8. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                        Worksofheart Level 1

                        Adobe, have you got any more information? I have provided you with a video, as you asked, can you tell me whether this is a known issue?

                        I mean, if there is no solution as well, I'd like to know, then we might change our production pipeline.

                        If you do have any other suggestions I'd love to know!

                        • 9. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                          Mukesh R Shah Adobe Employee

                          hi Marlies,

                           

                          We are not able to reproduce this issue on Win8.1 with Wacom Intuos 5.

                          Are you using your System in HiDPI mode?

                           

                          Can you please check what is the display resolution you have set on your system and also the default text?

                          Currently Flash Professional is not supported on HiDPI systems.

                           

                          Try foll. things :

                           

                          • Check what is the compatibility mode set : RightClick the FlashPro Application Shortcut -> Properties > Compatibility and checking the "Disable display scaling on high DPI settings" option.
                          • Set the custom text size (DPI) to 100% under ControlPanel->Display
                          • Set the screen resolution to 1280 x 1024

                           

                          Rgds,

                          Mukesh

                          • 10. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                            Worksofheart Level 1

                            I am not using a Wacom Intuos 5 but an Intuos 3.

                             

                            I am not using any HiDPI mode.

                             

                            My default monitor's resolution is 1920x1080. I will not scale my resolution down, due to our production pipeline and our industry's work standards.

                             

                            Default text size has always been 100%.

                            • 11. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                              severny Level 1

                              i have same issue ))

                              i check all the setting inside and outside of the program

                              check scratch disks

                              tablet setting

                              reboot few times )))

                               

                              but the thing was... my artwork was already too heavy )))

                              i made new file and everything goes nice ))

                              • 12. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                                Toonhaze Level 1

                                I am still struggling big time to solve this very annoying issue. This problem persists on several Wacom tablets (for me at least - I tried it on Intuos2 and Cintiq 21UX), several operating systems and several Flash versions.

                                 

                                AFAIR this problem is also present in Toon Boom Studio 8 so maybe it has something in common with Flash. Both programs are non-OpenGL vector drawing programs AFAIK so maybe they have something in common that creates this exact issue.

                                 

                                It might also be a bug inside the core of Flash itself, as it seems to be generating these microscopic double-clicks, when your pen tip touches the surface. And this affects not only your drawing/sketching (with lines not appearing) but also when you are using Transform Tool on objects for rotating, skewing, resizing. Sometimes, when I drag around a symbol, it accidentally ENTERS the symbol as if I double clicked it - but I haven't (deliberately).

                                 

                                This problem also affects your workflow when you use your timeline. Sometimes, when you drag within your timeline (using your pen) it just stops (again "double-click" issue).

                                 

                                The bottom line - everything in Flash (both GUI elements and the workspace) seems to be affected by this.

                                 

                                My assumption is, that when you use your pen, a various number of variables (pressure value, speed, frequency and strength of your strokes, tilt value, etc.) might create these "double clicks" out of thin air.

                                 

                                You can try and test it - even with a mouse. Select Brush Tool and double click somewhere in the drawing area - don't let go on the second click - now while holding the mouse button try and draw something... nothing is drawn.

                                 

                                If you try this trick in a program like "Gimp", "Alias Sketchbook Pro" or "Toon Boom Harmony 12" - no problem. These programs don't care about double-clicks.

                                 

                                Now the question is - what is generating these phantom double-clicks and how can this be helped?

                                 

                                When I am watching Youtube tutorials by Jazza or by Happy Harry they seem to do a lot of sketching in Flash and I haven't noticed them having any problems with dissapearing lines. They seem to be using older versions of Flash (CS3, CS5.5, CS6) and Windows 7.

                                 

                                I tried:

                                 

                                1). Lots of different drivers

                                2). Different combinations of settings in Wacom Tablet Properties

                                3). Windows 7 (64bit) and Windows XP (32 bit)

                                4). Different drawing tablets

                                5). A stationary PC with a single Nvidia graphic card, an old laptop with ATI card, a new laptop with dual GPUs (Nvidia and Intel)

                                6). 100 DPI

                                7). Different Compatibility settings (checkboxes like "Disable display scaling...")

                                8). High contrast theme, Aero theme

                                9). 1280x1024 monitor as Adobe says that this resolution is recommended

                                 

                                I am running out of options. But I still have hope. Adobe - please help!

                                • 13. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                                  Toonhaze Level 1

                                  Hi all

                                  (for TL;DR and the solution scroll down)

                                   

                                  I have had this problem for a very long time and finally found a solution. I have spent a lot of time and energy finding a fix and I now want to share it with everyone else. There is one downside to it, though - you will have no ability to double-click inside Flash (unless you have a suggestion for a workaround), but considering many other things that the solution will fix, it will be worth adapting your new workflow to the one without having to use double-clicks.

                                   

                                  The problem is that Wacom tablets seem to generate microscopic double-clicks at random times when using a Wacom pen. This is especially annoying when you use programs like Adobe Flash (or Animate) for things like drawing with the Brush tool. This would sometimes result in brush strokes appearing as dots and not lines. And if you have Use Pressure enabled (which most of you do when sketching or rough animating), not even a dot will appear on a failed line - the drawn stroke is not even generated.

                                   

                                  If you don't believe me that this problem exists in Flash, try going to Control Panel > Mouse and set your Double-click Speed to Slow (press apply). Then go to Flash, select Brush Tool and double click with it (using a pen or mouse) on the drawing area (don't release the mouse/pen on the second click). Now while you're still holding down the mouse/pen (after aforementioned double-click) try moving the mouse/pen. The dot is still there, the cursor is moving and nothing is drawn from the point where the dot is. Then you can test all of the following problems that I describe down below using this double-click trick. The problems affect: drawing, GUI element interraction like Timeline scrubbing, Symbol dragging, Transformation editing of an object.

                                   

                                  If you don't believe that your Wacom pen is generating these random Double-Clicks go to Control Panel > Mouse. Under the "double-click speed" section there is a little box with a folder that you can use to test your double-clicks on. Now use your Wacom pen to "draw" inside that little box using little strokes. What I mean by that is: imagine that the box with the folder inside it is your drawing space and you just have to draw tiny little lines WITHIN that box. Suddenly you will notice that the folder in that box opens/closes even though you didn't deliberately double-clicked in there. Connect this (Wacom random double-click) problem with aforementioned Flash-Double-Click problem and you can see how many things are affected by it. Maybe your Tablet is fine, but I tried this with 3 different tablets on different operating systems, using different drivers and different Flash versions - the problem seems to be universal.

                                   

                                  Main problems in Flash when double-clicks are generated (you can test this by provoking the double-clicks yourself):

                                   

                                  1). (Drawing): Draw something. Select it. Select Free Transform Tool to rotate, scale or skew it. Sometimes you click and drag with your pen on the transform handles and it's just not responding - you have to do it again.

                                  2). (GUI Elements): When you drag different windows inside Flash (like Color, Properties, Timeline windows, etc.). Let's say you want to move the Timeline window. A double-click is generated and the Timeline window is collapsed.

                                  3). (Timeline scrubbing): Sometimes, scrubbing the timeline also triggers the problem - the scrubbing does not register.

                                  4). (Dragging Symbols): Also, when you drag around a Symbol, sometimes with a randomly generated double-click it automatically enters the symbol (as if you would rightclick the Symbol and choose Edit Symbol) - this is so annoying because you then have to exit the symbol to move it and hope it does not happen again.

                                  5). (Other Drawing Tools): The problem can also happen when you use Pen Tool and Eraser Tool. And sometimes, when editing a shape of a line by dragging, it generates a double-click and selects everything, instead.

                                   

                                  In other words - nearly every element of Flash / Animate GUI (graphic user interface) is affected by this annoying bug.

                                  This becomes very frustrating in the long run - it was for me at least. Sometimes you just know which line to draw and where to draw it but once you start drawing it, it is not even appearing - pure anti-climax.

                                  This problem (the double-click bug) seems to appear around 10-20% of the times according to my testing.

                                  I had this issue on Windows XP (32-bit) and Windows 7 (64-bit). Even Windows 8 and Windows 10 didn't seem to solve the problem.

                                   

                                  TL;DR and SOLUTION: To fix the Wacom Tablet issue in Flash (for when your brush lines are not appearing or the user interface is not responding properly when interacting with it when using your Wacom pen) press Win+R (or go to Start > Run), type "regedit", press OK, go to HKEY_CURRENT_USER > Control Panel > Mouse, rightclick on "DoubleClickSpeed" entry to the right and choose Modify, change the value to "1", press OK, relog or reboot. To get your double click function back, simply change the value of "DoubleClickSpeed" to something higher like "200" (minimum) or "900" (maximum). Alternatively, you can do it by going to Control Panel > Mouse and playing with the slider of the Double-Click speed. Lowest value should be 200 and the highest 900. This is at least true in Windows7. I also tested this in Windows XP.

                                   

                                  Normally, I use my upper button of my Wacom pen for double-clicks (mostly for entering and exiting symbols) but after setting DoubleClickSpeed to "1" I can't seem use that button for double-clicks. So I found a temporary workaround solution. In Wacom Tablet Properties I assigned this button to Keystroke "Ctrl+E" which is a shortkey for Edit Symbol in Flash. Then in Flash I created a Command for "Exit Edit Mode" and assigned a shortcut "Ctrl+Shift+E". Now I can select a symbol, use my upper button to go inside it, go inside the next nested symbol, etc. And to go back to the main stage, I can hold down Shift and press my upper button (which will trigger "Exit Edit Mode") until I am in the main stage.

                                   

                                  Conclusion:
                                  In the beginning I thought that this problem was Flash-exclusive. But I saw similar behaviour in Toon Boom Studio 8. The same dots were generated sometimes, when drawing. Maybe it is a common problem for some vector drawing applications.

                                  After tons of research I tried many different things including going to Wacom Tablet Properties, setting Double Click Distance to "off", Disabling "Windows Ink", disabling lots of things in "Pen and Touch", etc. But nothing helped except this simple Regedit trick.

                                   

                                  EDIT: I think I just found a fix to solve the double-click issue in Flash and still be able to double-click using the Wacom pen button. The Regedit value of DoubleClickSpeed still has to be set to 1 (and you must remember to reboot or relog to apply changes). Now open Flash / Animate. Then open Control Panel > Mouse and fiddle with the Double-click speed slider (mine is set all the way to the left). DON'T press OK or Apply. Just leave it be. You should be able to draw in Flash and use the interface without problems and STILL be able to double-click stuff for like: renaming layers, entering and exiting symbols, etc. I haven't tested it out properly, but so far it seems to be working without any problems.

                                   

                                  I hope this helped someone out there fighing the same problems that I have. I am not quite ready to give up Flash, as it is still an excellent program for animations and drawing. Yes, Toon Boom Harmony has some great drawing tools and features that Flash doesn't have, but for many of us who are used to working in Flash and feel quite comfortable in it - well, now you have a fix

                                  If you have any other suggestions or fixes (especially regarding this double-click issue), please let us know.

                                  2 people found this helpful
                                  • 14. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                                    Preran Adobe Employee

                                    Thank you for sharing your solution with us.

                                    • 15. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                                      albertos72751698 Level 1

                                      Got same (an others) issues with brush in Animate CC, but I've tried same tablets,(cintiq 13HD y 22HD) in different MacOS versions, with different prior Flash versions and this problem doesn't appear.
                                      Tried with Flash 2015 CC and brush tool goes ok.

                                      Tried with CS6, and it works even better.
                                      Tried with CS3 and I cry remembering the good ol' days. THAT was a brush tool.
                                      Conclusion? Seems is not wacom's fault.
                                      Maybe you should check this post, (with photos and explanations) to know how Animate manages bezier nodes, compared with Flash.
                                      Please let me know your conclusions.

                                      Adobe Animate CC, brush tool worse than Flash.

                                      • 16. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                                        crwages Level 1

                                        Just got a wacom intuos pro last week and this is happening to me too in Photoshop when using the brush tool. I use a Mac but I don't think the OS is the issue.

                                         

                                        I'm so frustrated ... it happens to me at least 20% of the time too! I will try changing my double-click settings based on Toonhaze's thorough efforts and suggestions. If anyone has any other thoughts, please let me know.

                                         

                                        Thank you!

                                        • 17. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                                          albertos72751698 Level 1

                                          This is an Animate CC thread, not Photoshop. If you look for Photoshop's specific topics in the forum maybe you'll find a solution for your problem. Anyway, your issue is very strange in Photoshop.
                                          Good luck!

                                          • 18. Re: Brush tool creates (lagging) dots instead of strokes/lines 15% of the time
                                            Nipun Asthana Adobe Employee

                                            Hi All,

                                            Brush drawing experience has been improved in the latest update - Animate CC 2017.2 (16.2.0.24)

                                            Please try it out and let us know how it works for you.