1 Reply Latest reply on Feb 22, 2007 3:54 PM by kglad

    dynamic html text field

      Ok I have always had problems with dynamic text fields and fonts but now I am at a crossroads as to a problem. I have a component that fills a dynamic text field created at runtime that is html enabled but it seems to be not "catching" the tags. Now before someone gets on here and says:

      Did you set the txt.html = true?
      Did you assign the txt.htmlText = "some text"?
      Did you embed the fonts?
      YES-YES-YES within the component with all the glyphs I need ...meaning also the bolded/italic and regular. The tags are catching at authoring time when I am using the compiled clip. But at runtime they are showing < characters here is what I am tracing for the dynamic field at authoring time:

      <TEXTFORMAT LEADING="2"><P ALIGN="JUSTIFY"><FONT FACE="Arial Narrow" SIZE="12" COLOR="#000000" LETTERSPACING="1" KERNING="1">HTML <B>text</B> goes here...</FONT></P></TEXTFORMAT>

      Now when I do a trace at runtime this is what I am getting:
      <TEXTFORMAT LEADING="2"><P ALIGN="JUSTIFY"><FONT FACE="Arial Narrow" SIZE="12" COLOR="#000000" LETTERSPACING="1" KERNING="1">HTML &lt;b&gt;text&lt;/b&gt; goes here...</FONT></P></TEXTFORMAT>

      Now the only thing I can think of is that there is a race condition that is not catching the boolean or something before the text is rendered on the stage?

      Now the funny thing is the component I am working on is version 2...version 1 is the EXACT same code nothing has changed and it works but for the longest time it was having the same problems but ...boom it just started working when I set the txt.border = true.

      I was also thinking maybe the order of setting the particular properties was an issue or something so I did trace on the format and textfields and assigned them in order of which they are created. On other thing is I already tried embedding the fonts within the library that did not solve my issue.

      I was curious of kglad or another developer would have an answer to this.