1 Reply Latest reply on Feb 5, 2015 8:44 AM by m_vargas

    I can't install the new update into my MackBook Pro

    jerryd40079058

      When I tried to watch a video at a web site I got the blocked due to older version of Flash Player. I went through the download process over and over because when I tried to install the new one on my MackBook Pro I got an error message telling me " Adobe Flash Player cannot be installed. A newer version of the software is currently installed on your system. The installed version is 16.0.0.305, the new version is 16.0.0.296. This is as far as it will go but it doesn't resolve the problem. My Mac uses Safari as a web browser. Also why does Flash Player need updates so often?   Thanks  Jerry