1 Reply Latest reply on Feb 7, 2015 2:41 AM by han_solo

    Updating AIR 17.0 Problem

    han_solo

      Hi,

       

      Because of the issue here, I needed to update my AIR SDK to 17.0 . But updating rendered my Flash Builder to not open or act weirdly, let me explain:

       

      When I downloaded AIR SDK for Flex Developers from Download Adobe AIR 17 Beta - Adobe Labs, and extracted the files at FlashBuilder/eclipse/pluging/...compiler.../AIRSDK, FlashBuilder was behaving weirdly as such:

      Ekran Resmi 2015-02-07 11.30.24.png

       

      I guess it is due that these files doesn't include compiler, so I decided to download AIR SDK 17 & Compiler Beta, and copied the files to same directory (FlashBuilder/eclipse/pluging/...compiler.../AIRSDK). This time when I open FlashBuilder it showed this warning at start:

      Ekran Resmi 2015-02-07 11.36.09.png

      And when I tried to debug my application it doesn't show my application file at "Debug configurations...", and I was not able to "Set as Default Application" my AS file since it was disabled:

      Ekran Resmi 2015-02-07 11.38.43.png

      Also when I made any changes on my files and saved them, triggering project build, it showed this error:

      Ekran Resmi 2015-02-07 11.41.28.png

      And I decided to take the first warning seriously; I restarted FlashBuilder to see if the problem persists, this time FlashBuilder didn't even start. It showed splash screen, "Loading workbench" etc and silently closed. I repeated few times and it didn't change. When I restarted my computer it was opening once, behaving as described above and then when I restart doesn't open.

       

      I also downloaded and installed AIR 17.0 end user application to my computer and repeated all steps but it didn't work. Also I tried overwriting AIR SDK for Flex Developers files on my previous AIR SDK 16.0 which was working, but FlashBuilder didn't open at all.

       

      I would like to add that project was compiling and working normally before the update on FlashBuilder. Version of FlashBuilder is 4.7. I am a novice Mac OS user I may be skipping a very basic os-specific step.

       

      Thanks in advance.

        • 1. Re: Updating AIR 17.0 Problem
          han_solo Level 1

          Ok it seems I was trapped by double trouble. First was that I used AIR SDK for Flex Developers, which doesn't include a compiler. So I was convinced that problem is about updating AIR SDK. But using AIR SDK 17 & Compiler Beta was actually solving this problem.

           

          I was still not able to work on my project since I had another problem which I was blind to see: corrupted .actionScriptProperties file. It got corrupted with the last git merge I did, and it was not able to solve this problem from FlashBuilder since it was not letting me go into Project>Properties>.. Build Path, saying that it is corrupted.

           

          Finally I reverted to my last commit and I was able to reach properties. Problem solved.