9 Replies Latest reply on Feb 11, 2015 11:46 AM by tannv15314818

    How To Create A Website Background Video In Adobe Edge ?

    tannv15314818

      Hello,
      I have video file in my computer SSD drive and i want it to play as background on my web page (page that i am creating).I did try to follow this video:

       

      How To Create A Website Background Video In Adobe Edge Animate Using Edgehero - YouTube

       

      but i cant follow 100% what he is doing.

      Guide that i did try to follow is at this link: How To Create A Website Background Video In Adobe Edge Animate Using Edgehero - YouTube

      Steps i do in Adobe Edge Animate CC

      1.) Create New

      2.) i click + sign under section Library >> Scripts >> Add JS File from URL...

      URL that i am adding is: http://www.edgehero.com/edgehero.js/1.2/edgehero_1.2_min.js  (URL is taken from site: Edgehero.js )

      I add this link: http://www.edgehero.com/edgehero.js/1.2/edgehero_1.2_min.js to box that occures after i click on Add JS File from URL

      1.JPG

      3.) I go to Edgehero.js and from there i scrol down to section named as Media - Html5 video / Html5 audio
      and i select from there this:

      2.JPG

      there is a code:

        // this will set the video as background of the div/rectangle
      backgroundvideo_1 ='movie.mp4';
        // put new edgehero.js variables here

       

      4.) I go to Adobe Edge Animate CC 2014 and right click on project and select Open Actions for "Stage"

      3.JPG

      and then i click on + sign and select creationComplete4.JPG

      This will open Stage window

      there i will copy this code:
        // this will set the video as background of the div/rectangle
      backgroundvideo_1 ='movie.mp4';
        // put new edgehero.js variables here

      5.JPG

      5.) Then i click on ++ sign under library >> Video

      6.JPG

      and i add video from my computer SSD drive.
      Video is named as video3.mp4

      Now i eddit the code in Stage window (See above)
      code will look after editing like this:

      7.JPG

      Then i change under left side px to %

      8.JPG

      9.JPG

      6.) Then i copy backgroundvideo_1 from Stage Code:

      10.JPG

       


      Then i select Rectangle Tool and mark the area  (white box) and i click on small C icon
      11.JPG

       

      And the box that occures i type there backgroundvideo_1_mp4 autoplay
      now when i use ctrl and enter i only get gray box that does not play video.
      What am i doing wrong?