0 Replies Latest reply on May 26, 2015 3:01 AM by sh_internet

    Animate: two animations -- web font not applied in 2nd animation in IE

    sh_internet Level 1

      Hello,

       

      Edge animate has another problem:

       

      -- 2 animations are on the same webpage

      -- both animations are using the same webfont Vera Sans which is available in Dream Weaver and Animate

      -- If only one animation is placed on a webpage, the webfont Vera Sans will be applied.

      -- If both animations are on the same webpage (directly placed below the first, no extra CSS applied), the second animation is not displaying the web font, it is displaying a default font. This problem occurs in IE and is not visible in Chrome / Safari.

       

      If I change the order, it is still the first placed animation inside the HTML which works perfectly and the second is loosing the web font. What might be wrong here?

       

      Here a sample how to reproduce the error:

      1. Create a new Edge Animate project like Test_M_3

      2. Insert a new text object (width: 400px, height: 200px) and enter the following text: Test Man Errata PolyQ Zentauri Salut

      3. Set the text style by adding a web font "Vera Sans" only.

      4. Save your animation and publish using the Animate publishing package option.

       

      Adobe_Animate_Test_M_3.jpg

      5. Open Dreamweaver , create two DIV boxes and insert the edge animation in each DIV box.

       

      <!doctype html>
      <html>
      <head>
      <meta charset="utf-8">
      <title>Test Teaser</title>

      <script>var __adobewebfontsappname__="dreamweaver"</script><script src="http://use.edgefonts.net/vera-sans:n4,n7:default.js" type="text/javascript"></script>

      </head>

      <body>
      <div>
        <object id="EdgeID" type="text/html" width="570" height="420" data-dw-widget="Edge" data="../<your directory>/edgeanimate_assets/Test_M_3/Assets/Test_M_3.html">
        </object>
      </div>

      <div>
      <object id="EdgeID2" type="text/html" width="570" height="420" data-dw-widget="Edge" data="../<your directory>/edgeanimate_assets/Test_M_3/Assets/Test_M_3.html">
        </object>
      </div>


      </body>
      </html>

       

      6. Save your HTML file and open it in IE 11.

       

      The first DIV box is containing the animation with web font Vera Sans, the second DIV contains the animation with a default font. This is what I don't expect.
      This situation will not change if you save the animation a second time with a different name and use different names for the text object inside Animate.

       

      Adobe_Animate_Test_M_3_result.jpg

       

      Yours

      Stephan

       

      Nachricht geändert durch S Hofmann. Webfont added in <head> section.