0 Replies Latest reply on Feb 18, 2015 8:54 AM by owen.charles

    Fix for Flash player only working for admin account in Windows


      This is by no means the ONLY solution, but I found this to be the least intrusive, and quickest, for me.  I posted this because it may help others.  Frankly, this took me several hours!  What I like about this solution is that it will work for different versions of Windows and Flash.  In my case, I had Windows 8.1 32-bit with Adobe Embedded Flash Player.  Moreover, you won't need to uninstall/reinstall Flash and delete folders and registry keys.  For this reason, I found it less intrusive.


      I'd be interested in hearing back from others to see if this is a consistent solution for this problem.


      If Flash works for the admin account but not any of the user accounts, we can safely assume this is a permissions issue.  But where do we change the permissions? I tried to no avail in the Flash settings in Windows as well as the Flash settings console on the Adobe website.


      However, I found that I granted a specific registry key Read access to the machine's Users account, my issue was resolved.


      You'll have to do this with an admin account.  Type 'regedit' in the Windows search box.  Right-click and select 'Run as Administrator.'


      Navigate to this key: HKEY_CLASSES_ROOT\MIME\Database\Content_Type\application/x-shockwave-flash


      1. Right-click the key and select 'Permissions.'
      2. Grant the Users group on the local computer Read access.


      If the TrustedInstaller account is the owner of this key, you'll have to switch ownership to your admin account in order to do this.


      1. Right-click registry key
      2. Select Permissions
      3. Owner tab
      4. Change owner to <admin account>
      5. Apply
      6. OK
      7. Grant the Users group on the local computer Read access


      At this point you should be able to fire up IE and navigate to a site with a Flash video.  The issue should be resolved at this point.