3 Replies Latest reply: Apr 17, 2007 5:09 AM by snappet9 RSS

    Gave up and it worked.

    snappet9
      I struggled with clustering for a few days. The servers weren't failing over. For some reason it didn't seem to be properly adding the servers to the cluster. Is there a setting that I missed so that the servers are not only "added" to the cluster in a nominative way, but are also added in a "functional" way.
      I had basically given up on Friday, came in on Monday without having changed anything and it worked.
      This is the second time this has happened to me. The time before I went to lunch came back and it worked.
      So I guess I'm writing this for two reasons.
      1. Give up occasionally, take a break from clustering. Get a sandwich. Go for a walk. Annoy your co-workers.
      2. What is the setting that I may have missed that caused the delay?

      So, that's it.
        • 1. Re: Gave up and it worked.
          bdeen Community Member
          Did you bounce both servers? Also you might check your subnet and verify in security.properties in c:\jrun4\lib\ that they are both the same if they aren't (which mine weren't at one time) then you need to update the security.properties to identify the trusted hosts or the subnet restriction. when my subnet and the security.properties file was out of sync I would see weird clustering issues with my servers.
          • 2. Re: Gave up and it worked.
            snappet9 Community Member
            I did, and now something even weirder is happening!
            Now it is clustering, but when I try to go to a page it bounces back and forth like crazy.
            The page tries to server the page from the other machine creating a staccato/flicker effect.
            It is quite amazing!
            Have you, or anyone, seen this before and know what might be causing it?
            • 3. Re: Gave up and it worked.
              snappet9 Community Member
              Finally....
              I figured it out. You know what it was? I forgot to click the "Enable Java Session" checkbox. So if you are ever having the same problem.... RTFM.
              Duh....