9 Replies Latest reply on Feb 26, 2015 3:53 PM by gibson135

    Auto-keyframe problems

    gibson135

      So I see I'm not the only one with issues with the auto-keyframe option. After finally finding out that the icon is not where it used to be like every instructional video and reference book I have found shows, which has lead to much confusion and aggravation here, I have learned has has for some reason been relocated to the drop down menu.

       

      Here's the catch, it's already enabled and going on no matter what it says in that drop-down menu AND it already was without the icon being visible. If it wasn't, I would not have been looking for how to disable it??!!

       

      Anyone have any idea what's up? Why is it not just and icon on the menu bar like other choices. Personally I see both ways as useful. And more than anything else, seeing that big red hot reminding you that it is.. pretty useful in itself.

       

      Mainly- and please keep in mind that the drop-down menu at the left is NOT doing it- how can I disable the auto-keyframing?

       

      Thank you,

      Jim

        • 1. Re: Auto-keyframe problems
          Rick Gerard Adobe Community Professional & MVP

          If you have one keyframe set for a property, the next time you change anything you get another keyframe. If you don't want keyframes, turn off the stopwatch.

          • 2. Re: Auto-keyframe problems
            Tim Kurkoski Adobe Employee

            We moved the Auto-keyframe control from a button in the Timeline panel to the menu in the Timeline panel. The feature was not doing what we hoped it would do, which was help new users get started with making keyframes; instead it tended to cause confusion for both new and experienced users and interfered with new users learning how keyframes work.

             

            When you now enable Auto-keyframe from the menu, the Auto-keyframe icon will return. Th icon looks like it is a button, but it is not, and that is a bug. Clicking it does not affect enablement of Auto-keyframe. To disable Auto-keyframe you need to go back to the panel menu.

            • 3. Re: Auto-keyframe problems
              gibson135 Level 1

              It appears the way it now works is that the stopwatch is only seen (and red) when keyframes are enabled via the drop-down menu and that you have also to go to the drop-down menu to disable it. What this causes is that for one, the red stop-watch only there when enabled and also, clicking it while it's enabled (and red on the timeline) does nothing. The only way to get that red icon off of the timelines is to go to the drop-down menu and deselect it.

               

              The only way I can get no keyframes to occur automatically (since the red icon is only there when it is enabled and does nothing to select it AND the choice in the drop-down menu isn't doing anything after I've mad any) is to have NONE on that timeline and having it disabled via the drop-down menu.

               

              This isi version 13.2.0.49

              • 4. Re: Auto-keyframe problems
                gibson135 Level 1

                Was writing mine while yours was posted. Please still see mine though. Thanks.

                • 5. Re: Auto-keyframe problems
                  gibson135 Level 1

                  So to simplify my message which rambled to make sure the point was clear is the part that says even disabling it with the drop-down menu isn't doing anything if there is even one keyframe on that features timeline.

                  • 6. Re: Auto-keyframe problems
                    Tim Kurkoski Adobe Employee

                    Remember that even after you disable Auto-keyframe, once a layer property is enabled for keyframing (i.e., the Time-vary stopwatch is enabled, which happens when you make keyframes with the Auto-keyframe feature), After Effects will continue to make keyframes when you change the value of that property.

                     

                    This is the type of thing I meant when I said that Auto-keyframe tends to cause confusion. Using it effectively requires that you understand how keyframes work, which is almost the opposite of what our intent was for the feature.

                    • 7. Re: Auto-keyframe problems
                      gibson135 Level 1

                      So let me get this right.. because it is what just happened testing this out. It just doesn't seem possible.

                       

                      Auto Keyframe is off.

                       

                      To enable something to fade, I manually create a keyframe where the opacity is at 100%

                      I then select where I want it to be done fading, manually place a keyframe clicking the icon (at the point I have selected).

                      Enable Auto-keyframe is still not selected in the drop-down menu and there is no red keyframe icon seen (of course).

                      Keyframes now happen with any adjustment

                       

                      This is what is intended? Auto-Keyframing was never put to use before it was permanently there.

                       

                      If so- which means once a keyframe has been placed- are we not able to experiment without making endless keyframes even though it's supposedly disabled???

                       

                      Is there another way to automate I'm missing?  How are we able to experiment? I must be missing something.

                      • 8. Re: Auto-keyframe problems
                        Tim Kurkoski Adobe Employee

                        Keyframes now happen with any adjustment

                        This is the way After Effects has always worked, long long long before the Auto-keyframe feature was added.

                         

                        Step 1: Enable the Time-vary stopwatch for a property.

                        Step 2: Change the value of that property at any point in time.

                        Result: A keyframe is created. If a keyframe exists at that point in time, its value is changed.

                         

                        If you're new to After Effects, I strongly encourage you to go here and start reading: http://adobe.ly/AE_basics

                        • 9. Re: Auto-keyframe problems
                          gibson135 Level 1

                          Thanks

                          - I guess the thing is the option "enable auto-keyframing" is bit misleading since it really isn't an option once you've done decided to use any. 

                           

                          I'm familiar with them as used with digital recording and mixing and it is different. I'll just have to get used to that.