3 Replies Latest reply on Feb 16, 2007 7:47 AM by kurt.iverson

    Weird WSDL

      I made a CFC that runs great locally. But when I try to publish it as a web service I get this weird error

      If the requested WSDL document can't be retrieved or it is dynamically generated, it is likely that the target web service has programming errors.

      Fatal Error: URI=null Line=5: Comment must start with "<!--".

      When I look at the webservice (eg. myService.cfc?wsdl) It shows this line jammed inside the wsdl file :

      <!-- WSDL created by Macromedia ColdFusion MX version 7,0,1,116466

      Why would my helpful CF server start inserting comments? Is this a version problem?
        • 1. Re: Weird WSDL
          I am having the same problem! Any thoughts on why?
          • 2. Re: Weird WSDL
            123red Level 1
            It might be a permssions issue... Does your CFC have any permissions? Mine is accessing a database table that requires a username and password.

            But the error message is so ambiguous I have no idea. If I hit the CFC locally it works fine, as soon as I try to publish, it breaks with this completely cryptic message.
            • 3. Re: Weird WSDL
              kurt.iverson Level 1
              Here's how I was able to resolve my issue. I was calling my cfc that lives on a machine running the development version of ColdFusion from another test server. It turned out I had reached the two client access limit. I cleared this up by rebooting my developer machine everything works fine. Not sure if this helps with your problem.