1 Reply Latest reply on Feb 28, 2015 11:39 AM by johnrellis

    Problems with metadata being changed.

    j013

      Recently I started getting a down arrow appearing on 'all new' imported images, informing me that Metadata has been changed in Lightroom. As I import directly from the CF card directly into LR, as a DNG copy and have been doing so for years with absolutely no problem, I don't know what has suddenly changed? I rang Adobe for support and after getting remote assisted help finally got it sorted, or so I thought. Today I imported some new RAW images, which appeared arrow free, (although I now see that arrows have reappeared on other recent 'unedited' imports), but as soon as I did any editing in the develop mode the arrows appeared again and I now have to manually save the metadata changes to disk which I have never done before. Can anyone help me with this issue? 

        • 1. Re: Problems with metadata being changed.
          johnrellis Most Valuable Participant

          People have been complaining about spurious metadata-change indicators for years, since at least LR 3. Some of the bugs (e.g. with metadata fields containing newlines on Windows) were fixed in LR 4, but based on user posts, it seems that problems remain in LR 5.    Often, it seems that you've identified a workaround and the metadata-status indicators disappear, only to reappear later -- this is because LR is scanning for changes in background.

           

          Do you renaming files automatically on import?  If so, you might try turning that off and see if that helps.

           

          You can read other users' posts about this problem in the official Adobe feedback forum: Search results in Photoshop Family. Maybe they will give some clues for a workaround that works for you. 

           

          Generally, though, a number of people just ignore the spurious indicators.  If you turn on the setting Catalog Settings > Automatically Write Changes Into XMP, then the metadata gets correctly written back to the files very soon after any actual changes are made.  And you can then turn off the indicator in grid view via View > View Options > Grid View > Cell Icons > Unsaved Metadata.