0 Replies Latest reply on Mar 2, 2015 7:04 AM by jackh31395862

    Cannot download an ebook under Adobe DRM

    jackh31395862

       

      I have installed Adobe Digital Editions, and have previously downloaded an e-book and accessed it successfully. I have more recently purchased an e-book from a vendor in Australia, which is available under an Adobe DRM arrangement. In accordance with the vendor's instructions I registered an Adobe ID and password with ADE. I then selected DOWNLOAD EBOOK on the vendor's website, and it downloaded a file called URLLink.acsm.  If I run this file without ADE running, nothing happens.  If I run it with ADE running, I get the error message "Error! Check activation." And no download of my recently purchased book, though I can still see and access the book I downloaded previously (which did not involve DRM).  The vendor suggested that I "Erase Authorisation" in ADE.  When I tried that (many times) I got the error message "Unable to Erase Authorisation. Please try after some time".  The vendor then suggested uninstalling and re-installing ADE, but nothing changed.