1 Reply Latest reply on Mar 2, 2015 8:55 AM by Joel Cherney

    Placing Text With Digits - the Digits Come Out in the Wrong Language

    ElishevaH Level 1

      I am using CS4 ME. When I place English text from Word into InDesign, the English text comes out okay but the digits in the text come out in Arabic. In the character menu, the setting for the digits is "default". When I set the digits to be in Arabic, they come out in English (1,2,3 and so on). How can I make it right so that the default will be 1,2,3..... and when the setting is Arabic in the file it will be Arabic?

        • 1. Re: Placing Text With Digits - the Digits Come Out in the Wrong Language
          Joel Cherney Adobe Community Professional & MVP

          Digits respect language settings, so if the paragraph is marked as English, you'll get correct digits for English. Farsi, you'll get correct digits for Farsi. Set the digits for "Default" to get this behavior.

           

          However, note that the proper name of digits used by writers of English and European is Arabic digits, and the proper name of digits used by writers of Arabic is Hindi digits. This is because Europe got all of its upper maths from the Arabic world (when they had a flourishing civilization and Europe was hella barbaric). If you look at it, algebra is obviously an Arabic word (al-gebr).

           

          So if you mark digits as "Arabic" then they will be 1,2,3 even if it's Arabic text marked as Arabic in the paragraph style. Trust InDesign's default language settings here.