8 Replies Latest reply on Apr 25, 2015 11:22 PM by kareemb29232627

    ADE is not opening my .ACSM files and not letting me DEAUTHORIZE

    sitwat1994

      So I am trying to download an e-book from my university's library and am unable to open it on Digital Editions. I downloaded Abode Digital Editions as it was instructed to do so on my library website. So I downloaded the file and tried to open it on ADE but was met with "Error. Check Activation!" notification. After looking up online I tried everything from deauthorizing/reauthorizing, uninstalling, unblocking the files and downloading an older version and I restarted the computer too. 2.png3.png

      Nothing worked so I kept searching. Many users kept insisting that Ctrl+Shift+D worked for them and so I gave it a go another time but unfortunately, I find myself am unable to deauthorize. Because every time I time my password it says "Unable to Erase Authorization.

      1.png

      Please try after some time." Please I really need some help because I don't want to fail and the textbook prices are sky high.


      Please and thank you! -hugs-