11 Replies Latest reply on Feb 15, 2007 3:52 AM by usureka

    HTML BANNER

    usureka
      I want to create a HTML Banner (software name and the company logo) and make it available in all the topics of the robohelp file. I'm inserting the image using Insert>Headers and footers. but i'm getting a blank space at the top of the final output...Pls help me to do this properly.
        • 1. Re: HTML BANNER
          CraigCC Level 2
          Hi usureka,

          you need to use the templates feature.
          Create a template and add the banner to the header along with any text.
          Apply that template to the topics where you wish the banner to appear.

          You may find it easier to pop the banner in a table when working in the header.

          Does this help
          Kind Regards
          Craig
          • 2. Re: HTML BANNER
            usureka Level 1
            Thanks Craig...i'm able to do it...but 've some minor constraints in this....i've created a image (company name and logo)>created a template>added that image as a header in that template>applied that template to the required topic too....

            but in the final output when i'm seeing the logo (header) why am i getting a blank space at all the sides. (i want this to be attached without any spaces at the edges..). pls help
            • 3. Re: HTML BANNER
              CraigCC Level 2
              Hi usureka,

              Sorry, I need a bit more information here - trying to visualise this problem.
              What blank space? Do you mean the blank space between the edge of the graphic and the edge of the help window?
              Does this mean you do not want the edge of the logo to line up with the edge of the text within the topic?
              What output of RH are you generating and which verson of robohelp are you using?

              thanks
              Craig

              • 4. Re: HTML BANNER
                usureka Level 1
                Yes as you clearly stated, I mean the blank space between the edge of the graphic and the edge of the help window..
                I want the left edge of the graphic to be lined up with the line that is present as a separator after the contents menu and ofcourse the upper edge of the graphic to be lined up with the line that is present as a separator at the top portion of the help window...Am i bit clear....Is this possible....
                Note: I'm generating a WebHelp using Adobe RH6.
                • 5. Re: HTML BANNER
                  CraigCC Level 2
                  Yes you can achieve this by changing the margin attribute of the body tag in the stylesheet.

                  1. Open up the stylesheet (.css) file.
                  2. Find the body tag - usually at the top.
                  3. Add the following attributes:

                  margin-top: 0;
                  margin-right: 0;
                  margin-left: 0;

                  4. Save the stylesheet.
                  5. You can see the result in the preview window as well as the webhelp output.

                  Does this help?
                  thanks
                  Craig
                  • 6. Re: HTML BANNER
                    usureka Level 1
                    Hello sir...Thanks for the clear steps but i'm sorry to say that i'm still not achieving it.....how is the body tag interconnected with the header which i've created....i'm not able to get it.

                    Moreover i tried to do the steps you've mentioned.

                    my paragraphs are marked with the style named:"Normal"...i don't find a style named "Body" alone...in my CSS and even in Default CSS... i could only find a style named "Background + Text (Body)...and when i was trying to modify it...paragraph option under format menu was not getting highlighted...then i tried to modify the style named "Normal"....i could find only the indentation (Left and right), which has been mentioned as 0pt, 0pt respectively...and im not able to locate the margin properties....

                    i think i'm wrong somewhere....pls help me....
                    • 7. Re: HTML BANNER
                      CraigCC Level 2
                      Hi usureka,

                      quote:

                      i think i'm wrong somewhere


                      Only that you are posting the question in a forum for RoboHelp HTML users :-)
                      Are you using RoboHelp for Word by chance? This is a different tool and the solution I posted will not work for RoboHelp for Word - the tool works entirely differently.

                      You should post any Robohelp for Word issues in the RoboHelp for Word FORUM.

                      My guess is that you will need to edit the .css that is generated in the webhelp output folder and and modify the body tag there. Obviously this will get overwritten each time you generate the help.

                      Sorry I cannot be more help right now
                      Craig
                      • 8. Re: HTML BANNER
                        Peter Grainge Adobe Community Professional (Moderator)
                        usureka

                        You emailed me and I replied. No response to that. ???
                        • 9. Re: HTML BANNER
                          usureka Level 1
                          Sorry sir, i was on leave...as per request, i've zipped the file and mailed it to you..
                          • 10. Re: HTML BANNER
                            Peter Grainge Adobe Community Professional (Moderator)
                            I've replied to you offline and will look at the file later.

                            By the way, sounds like you are from a country or background where formality is still the normal way. We are a pretty informal bunch here so please feel free to call me Peter.

                            • 11. Re: HTML BANNER
                              usureka Level 1
                              Hi craig :-) I've posted this to the correct forum i believe......i feared to touch the true code as i was not that much familarized with the HTML Codes and was trying to set the margin just by opening the CSS and trying to modify the style......Now i got what i wanted after doing what you said :-) Thanks to Peter too who gave solution offline :-)