2 Replies Latest reply on Mar 10, 2015 5:18 AM by PIBZY

    Hello! I've had Adobe Premiere Elements 12 on my windows 8 laptop for a long time now. It's worked great, but lately, I cant launch it. I'll double click the icon and it simply WILL NOT LAUNCH. I am a youtuber and I REALLY NEED TO GET BACK TO MAKING VIDEO

    PIBZY

      Hello! I've had Adobe Premiere Elements 12 on my windows 8 laptop for a long time now. It's worked great, but lately, I cant launch it. I'll double click the icon and it simply WILL NOT LAUNCH. I am a youtuber and I REALLY NEED TO GET BACK TO MAKING VIDEOS :(. How do I fix this???

        • 1. Re: Hello! I've had Adobe Premiere Elements 12 on my windows 8 laptop for a long time now. It's worked great, but lately, I cant launch it. I'll double click the icon and it simply WILL NOT LAUNCH. I am a youtuber and I REALLY NEED TO GET BACK TO MAKING V
          John T Smith Adobe Community Professional & MVP

          NOTE - McAfee kills the program http://forums.adobe.com/thread/1460089?tstart=0
          From the Premiere Elements Information FAQ http://forums.adobe.com/thread/1042180
          •You MUST use an account with Administrator Privileges to run Premiere Elements
          •(Doing Run as Administrator http://forums.adobe.com/thread/969395 [says Encore and also for "All" versions of Premiere] will sometimes fix "odd" errors)
          •What version of Premiere Elements? Include the minor version number (e.g., Premiere Elements 12 with the 12.1 update)
          •What operating system? This should include specific minor version numbers, like "Mac OSX v10.9.4"---not just "Mac"
          •Has this ever worked before?  If so, do you recall any changes you made to Premiere Elements, such as adding Plug-ins, brushes, etc.?  Did you make any changes to your system, such as updating hardware, printers or drivers; or installing/uninstalling any programs?
          •Have you installed any recent program or OS updates? (If not, you should. They fix a lot of problems.)
          •What kind(s) of image file(s)? When talking about camera raw files, include the model of camera.
          •If you are getting error message(s), what is the full text of the error message(s)?
          •What were you doing when the problem occurred?
          •What other software are you running?
          •Tell us about your computer hardware. How much RAM is installed?  How much free space is on your system (C:) drive?
          •How many and what speed are your hard drive(s)... ie 5400rpm or 7200rpm or?
          And some other questions...
          •What are you editing, and does your video have an orange line over it BEFORE you do any work?
          •Which version of Quicktime do you have installed?

          •What is your exact brand/model graphics adapter (ATI or nVidia or ???)
          •What is your exact graphics adapter driver version?
          •Have you gone to the vendor web site to check for a newer driver?
          •For Windows, do NOT rely on Windows Update to have current driver information
          •-you need to go direct to the vendor web site and check updates for yourself
          •nVidia Driver Downloads http://www.nvidia.com/Download/index.aspx?lang=en-us
          •ATI Driver Autodetect http://support.amd.com/en-us/download/auto-detect-tool
          -and a fix for at least "some" ATI crashes https://forums.adobe.com/thread/1553342

          • 2. Re: Hello! I've had Adobe Premiere Elements 12 on my windows 8 laptop for a long time now. It's worked great, but lately, I cant launch it. I'll double click the icon and it simply WILL NOT LAUNCH. I am a youtuber and I REALLY NEED TO GET BACK TO MAKING V
            PIBZY Level 1

            I have a windows 8.1, and the software is Adobe PE12, not 12.1. I bought my laptop along with PE12, and when I got home I installed it and since then it has worked. But about two weeks ago it stopped working. During the first week or so, the launcher would open but selecting new project or existing project would have no effect. Now it simply will not launch.

             

            What are you editing, and does your video have an orange line over it BEFORE you do any work?  

             

            No, my videos dont have "orange lines over them".

             

            Tell us about your computer hardware. How much RAM is installed?  How much free space is on your system (C:) drive?

             

            I have about 150 G free on my 499 G laptop. But Adobe was working fine even when there was 10 G left one time. Also, I've installed allot of programs on my laptop. Could it be a virus or something ? I've been looking for new screen recorders and minecraft mods and have been downloading almost every one I can get that looks safe, but still, it could be them. i try to delete those whenever I can, too. And I'm not sure what RAM is or how much is installed.

             

            If you are getting error message(s), what is the full text of the error message(s)?

             

            No I am not getting error messages. Just...nothing.

             

            What were you doing when the problem occurred?

             

            I went downstairs to my room and turned on my laptop to edit a film. I tried to launch Adobe PE12 and the launcher came on, but when I clicked new project I would only get the black and purple stripes indicating that it was loading, but nothing happened. Eventually it would stop loading and clicking it again would have the same results.

             

            I'm sorry, but some of these questions I don't know the answers to or I simply dont understand them. But remember that PE12 was working fine before and then out of the blue it stopped wrking. So I probably don't have any missing system requirements or anything. But thank you for replying, and I hope we can get this fixed!