1 Reply Latest reply on Mar 11, 2015 2:55 PM by johnhawk666

    Lightroom Won't Open - Activation Just Loops

    RodPullman

      Would greatly appreciate some expert help with this.  I've tried to use Adobe Chat, but have been kept waiting for hours without any response. 

       

      I purchased the boxed version of Lightroom 3 from Adobe some years back, installed it on my iMac.  It was working at one time, though I did not use it much.  (I also purchased CS5.5 creative suite, parts of which I use all the time.)

       

      Recently I tried to open Lightroom 3 but the program wouldn't open.  It asked me for my serial number.  So, I entered it and filled out the registration (again), and tried to open the program. Clicking on the icon only brought up the window asking if I want to buy the program or else enter the serial number.  So I repeated the process.  Same result.  Click on the Lightroom icon and the same window pops up, asking for the serial number.

       

      I can't get past this loop.

       

      Can anyone tell me what steps to follow in order to get Lightroom working again?

       

      Thanks in advance for your help.

       

      -Rod

       

      rodpullman@gmail.com